lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 04-11-2012, 02:18 PM   #1
Chuckie
Getting Wild
 
Join Date: Jun 2010
Posts: 77
Default pedal playing

Why is it on both of my club cars that you have to play with so much with the pedal to get the engine to turn over and start. It seems that it happens most often when I go to use it for the first use of the day and occassionally during the day. I thought the battery may be low but i charged it and didn't make a difference.
Chuckie is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 04-11-2012, 11:14 PM   #2
fastercarter
Gone Wild
 
Join Date: Jan 2012
Posts: 359
Default Re: pedal playing

Quote:
Originally Posted by Chuckie View Post
Why is it on both of my club cars that you have to play with so much with the pedal to get the engine to turn over and start. It seems that it happens most often when I go to use it for the first use of the day and occassionally during the day. I thought the battery may be low but i charged it and didn't make a difference.
Check the S/G belt tension. TIGHT is good.

FC
fastercarter is offline   Reply With Quote
Old 04-25-2012, 02:15 PM   #3
Chuckie
Getting Wild
 
Join Date: Jun 2010
Posts: 77
Default Re: pedal playing

Well, That worked on my carryall but not my DS. Do you think a battery going bad could be the culpript. Seems aliitle better after charging but still hesitant
Chuckie is offline   Reply With Quote
Old 04-25-2012, 04:48 PM   #4
DOOmsman
Gone Wild
 
DOOmsman's Avatar
Yamaha
 
Join Date: Jul 2008
Location: Reddick IL
Posts: 11,107
Default Re: pedal playing

Hook up a volt meter and check the voltage standing and starting.
Also clean all cable connections.
DOOmsman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
CC playing on the pond Videos


All times are GMT -5. The time now is 10:50 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.