lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-11-2018, 10:19 AM   #11
Laynems
Not Yet Wild
 
Join Date: May 2018
Posts: 6
Default Re: '06 G22 ran when purchased, trailered home won't start

Okay so I found the problem and it is definitely out of my area of expertise as I have little experience but want to give it a shot. The pushrod on I believe the exhaust valve came off after inspection. However, when I tried to put it back on, it keeps coming off immediately. After reading previous threads, it looks like A) I need to see if it is bent by rolling on glass surface - it doesn't look bent just looking at it B) I need to set the valves at TDC to .004. I'm wondering also if a stuck valve is why it keeps slipping off also. Help, advice on best course of action please?
Laynems is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-11-2018, 10:40 AM   #12
expo
Not Yet Wild
 
expo's Avatar
Yamaha
 
Join Date: Oct 2017
Location: Lodi, Ohio--Florida when it's cold
Posts: 47
Default Re: '06 G22 ran when purchased, trailered home won't start

A compression gauge will lay around in your tool box for years but when you need it-YOU NEED IT. Try squirting some oil on the valve stem and work it up and down by hand and see if it gets easier. Yeah check that push rod for true on a flat surface. Good luck
expo is offline   Reply With Quote
Old 06-12-2018, 11:45 AM   #13
Laynems
Not Yet Wild
 
Join Date: May 2018
Posts: 6
Default Re: '06 G22 ran when purchased, trailered home won't start

Got it running yesterday! Thank you all for the help and suggestions, much appreciated. It turned out to be a sticky intake valve that was gummed up presumably by bad gas as I don't think it was ran very much in the last year. Ended up pulling the head and cleaning the valves as there was very sticky residue all over the valve and in the port.
Laynems is offline   Reply With Quote
Old 06-13-2018, 08:56 PM   #14
cgtech
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 17,437
Default Re: '06 G22 ran when purchased, trailered home won't start

Had to do that to an entire group of carts that all did the same thing.
cgtech is offline   Reply With Quote
Reply

Tags
g22 crank no start, g22 won't start
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
What have I purchased? Gas golf carts
Just purchased an EZ-GO Xi 875 Electric EZGO


All times are GMT -5. The time now is 03:18 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.