lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-22-2009, 08:18 PM   #1
well driller
Not Yet Wild
 
Join Date: Apr 2009
Posts: 1
Default G1 speeds up, slows down

We have a 1989 G1 that will go, sometimes at full speed then slows down to nothing. Had old gas, put in new gas. Cleaned carb, changed fuel filter, changed plug, changed all fuses, checked air filter, cleaned fuel bowl. When it is jacked up, the drive belt engages fine and runs fine but when we go to drive it, it has no power.
well driller is offline   Reply With Quote
 
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
04 CC takes off normal then slows down. Electric Club Car
Backfire at slow speeds Gas EZGO
g-1 starts hard wont run at low speeds Gas Yamaha
88 Marathon 2 Cycle won't run correctly at low speeds Gas EZGO
touchy gas pedal at slow speeds Gas Club Car


All times are GMT -5. The time now is 01:37 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.