lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 05-24-2011, 10:43 AM   #1
leapingbuddha
Getting Wild
E-Z-GO
 
Join Date: Dec 2009
Location: Moiser, Oregon and Baja
Posts: 95
Default Cart Stopped:need help, overHH

Happily motoring down hill at app 30 mph my cart felt like I was getting no power. So pulling over to a secondary road and continuing on another 300 yds I decided to look under the hood. Should have continued on home as the cart would not go. Put it in TOW and flagged over a friend. Checked things out as best I could. It was acting the same as when the controller went one year ago. Talked to Richard at Alltrak and sent it in. Richard said I had a blown transistor. Well still no go. Is it the motor? I have 22.7 volts between the negative on the battery post and the frame or on the motor casing. Is it time for Plum-Quik to send me a Bandit? Help, been down 4 weeks
leapingbuddha is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 05-24-2011, 11:01 AM   #2
madoc1
no clue
 
madoc1's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: spicewood, texas
Posts: 3,308
Default Re: Cart Stopped:need help, overHH

you shouldn't have any voltage going thru the frame. is this all the time or just when activate the solenoid? sounds like you might have over reved the motor if it is only when you step on the pedal. if you are not activating the sol. there should be no voltage anywhere except one large post on the solenoid.
madoc1 is offline   Reply With Quote
Old 05-24-2011, 11:22 AM   #3
scottyb
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 70,695
Default Re: Cart Stopped:need help, overHH

My best guess is ... The motor over reved and came apart.
scottyb is offline   Reply With Quote
Old 05-24-2011, 12:00 PM   #4
leapingbuddha
Getting Wild
E-Z-GO
 
Join Date: Dec 2009
Location: Moiser, Oregon and Baja
Posts: 95
Default Re: Cart Stopped:need help, overHH

This is with the key off. It seems like half the voltage of the battery pack which is 40 volts
leapingbuddha is offline   Reply With Quote
Old 05-24-2011, 12:45 PM   #5
madoc1
no clue
 
madoc1's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: spicewood, texas
Posts: 3,308
Default Re: Cart Stopped:need help, overHH

pull one of the cables off the large posts and check continuity. it should read zero ohms. if it doesn't, that is a bad solenoid and one of your problems.
you could also pull the cables off the motor and make sure there is no continuity between the studs and the motor frame.
madoc1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
cart stopped running need help! Gas EZGO
cart stopped working Electric EZGO
cart stopped Electric EZGO
Cart just stopped Electric Club Car
cart just stopped Electric Yamaha


All times are GMT -5. The time now is 08:07 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.