lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 12-26-2007, 12:08 PM   #1
amanda1
Not Yet Wild
 
Join Date: Dec 2007
Posts: 60
Default please help

well I knew it was to good to be true :( after all that work fixing the golf cart now there is gas in the oil and the cart wont run. We are a rescue and it may cost to much to fix, any ideas?


amanda
amanda1 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 12-26-2007, 12:15 PM   #2
NO NO NO E-Z-GO!
Gone Wild
 
Join Date: Dec 2006
Location: ComplainAboutNoNo'sProfile-Ville
Posts: 4,995
Default Re: please help

Do you have a compression gauge? If you do, check the compression and let us know what it is. If you don't, borrow one from AutoZone or a friend.

With gas in the oil, I would not run the cart for long. However, so as to not ruin new, clean oil, we'll try to at least get it running on what's in there.

Does the engine have spark now? Have you had to choke it a lot lately?
NO NO NO E-Z-GO! is offline   Reply With Quote
Old 12-26-2007, 07:11 PM   #3
Riorat
supervision required
 
Riorat's Avatar
Club Car
 
Join Date: Dec 2007
Location: Augusta AR.
Posts: 2,225
Default Re: please help

Mine had gas in the oil back in May, but it still ran, Smoked BAD, took the carberater off took it apart and cleaned it, and it has run fine every since.
Riorat is offline   Reply With Quote
Old 12-26-2007, 08:15 PM   #4
amanda1
Not Yet Wild
 
Join Date: Dec 2007
Posts: 60
Default Re: please help

ours has a brand new carb. we took it 45 minutes away into town the guy said it could be one of a couple things. we are waitiong to hear back from them then decide what to do. If it costs to much we may just get a used motor.
amanda1 is offline   Reply With Quote
Old 12-26-2007, 09:44 PM   #5
wish2fish
Gone Wild
 
Join Date: Dec 2007
Posts: 391
Default Re: please help

Quote:
Originally Posted by Riorat View Post
Mine had gas in the oil back in May, but it still ran, Smoked BAD, took the carberater off took it apart and cleaned it, and it has run fine every since.
I had this problem on a lawnmower and this was the problem as well.
wish2fish is offline   Reply With Quote
Old 12-27-2007, 03:00 AM   #6
phasetim
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: please help

before you buy a motor try replacing the fuel pump..

they can break, allowing the gas to flow in through vacumn and fill up motor..
phasetim is offline   Reply With Quote
Old 12-28-2007, 10:17 AM   #7
amanda1
Not Yet Wild
 
Join Date: Dec 2007
Posts: 60
Default Re: please help

we still have not heard back from the repair man :(
amanda1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 01:18 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.