lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 02-11-2014, 05:44 PM   #1
Xtreme Cartz
The Fabricator
 
Xtreme Cartz's Avatar
 
Join Date: Dec 2006
Posts: 2,012
Default Starting issues 94 DS

I have a 94 cc ds that is acting strange. It quit running suddenly going down a bumpy gravel road and then it would not restart. After I cleaned the carb it ran again. I also replaced the fuel pump, fuel line, fuel filter, drained the old gas out of the tank and refilled with new gas. Well its been sitting for a couple weeks as the weather has been too cold to ride. I wanted to get it ready to ride in the snow we are supposed to get tonight but now it wont start again.

When I try to start it by pressing the choke button it wont start. It will only start if I cover the carb inlet with my hand or squeeze the air intake hose shut. Why would this be?
Xtreme Cartz is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 02-11-2014, 07:16 PM   #2
nobuckbuild
Gone Wild
 
nobuckbuild's Avatar
E-Z-GO
 
Join Date: Mar 2012
Location: CENTRAL PENNSYLVANIA
Posts: 1,466
Default Re: Starting issues 94 DS

one of two things check the fuel line first from the carb and pump into a glass jar you should get a good stream squirting if not check for oil in the vac line going to the engine , if thats not the problem pull the carb and check what you have in the bowl you may have got ahold of some of the great ethanol gas that turned and has the bowl filled with water causing the carb to draw gas when you cut off the air and force it to swallow the water to get a little gas to fire over


ps also check that glass jar for gas seperation you'll have milky water on the bottom and gas on top

pure-gAS.ORG PLEASE EVERYONE SAY YOURSELF SOME HEADACHES AND BUY ETHANOL FREE GAS FIND A STATION I KNOW I DRIVE 50 MILES ONE WAY TO GET GAS FOR ALL OF MY SMALL ENGINES
nobuckbuild is offline   Reply With Quote
Old 02-15-2014, 10:52 PM   #3
Xtreme Cartz
The Fabricator
 
Xtreme Cartz's Avatar
 
Join Date: Dec 2006
Posts: 2,012
Default Re: Starting issues 94 DS

It's not pumping a steady stream of gas. I blew compressed air back through the fuel lines to make sure they weren't plugged. I pulled the pulse line off the fuel pump but couldn't tell anything from it. Just for good measure I blew compressed air through the pulse line into the engine which made the dip stick shoot up and hit me in the face. When I turn the engine over I can tell there is vacuum in the pulse line.

So why would both my old and new fuel pumps stop delivering fuel?
Xtreme Cartz is offline   Reply With Quote
Old 02-16-2014, 04:16 PM   #4
tacomaman
Not Yet Wild
 
tacomaman's Avatar
Club Car
 
Join Date: Feb 2012
Location: York,SC
Posts: 44
Default Re: Starting issues 94 DS

have you by chance checked the pick up tub coming out of the tank? its possible there is a blockage there.
tacomaman is offline   Reply With Quote
Old 02-16-2014, 04:54 PM   #5
Xtreme Cartz
The Fabricator
 
Xtreme Cartz's Avatar
 
Join Date: Dec 2006
Posts: 2,012
Default Re: Starting issues 94 DS

yes I did that today. I checked the pickup tube and the elbow that unscrews from the tank. They were clear. I'm mystified at this point. Everything put together, seems like it should be pumping gas.
Xtreme Cartz is offline   Reply With Quote
Old 02-16-2014, 05:22 PM   #6
tacomaman
Not Yet Wild
 
tacomaman's Avatar
Club Car
 
Join Date: Feb 2012
Location: York,SC
Posts: 44
Default Re: Starting issues 94 DS

well...if your new fuel pump is pumping fuel to the carb...may need to take carb back off and clean it again and make sure the plastic spacer that go to the head isnt cracked.
tacomaman is offline   Reply With Quote
Old 02-16-2014, 07:01 PM   #7
Xtreme Cartz
The Fabricator
 
Xtreme Cartz's Avatar
 
Join Date: Dec 2006
Posts: 2,012
Default Re: Starting issues 94 DS

No the fuel pump is not pumping gas. When I disconnect the fuel line from the carb and turn the engine over, no gas comes out. Also the fuel filter is dry.
Xtreme Cartz is offline   Reply With Quote
Old 02-16-2014, 07:20 PM   #8
tacomaman
Not Yet Wild
 
tacomaman's Avatar
Club Car
 
Join Date: Feb 2012
Location: York,SC
Posts: 44
Default Re: Starting issues 94 DS

sounds like a faulty fuel pump then. i see youve already checked the vacuum line to the motor. these newer plastic fuel pumps we get at the shop arent as good as the older metal ones.
tacomaman is offline   Reply With Quote
Old 02-16-2014, 09:58 PM   #9
Xtreme Cartz
The Fabricator
 
Xtreme Cartz's Avatar
 
Join Date: Dec 2006
Posts: 2,012
Default Re: Starting issues 94 DS

Do you ever have to somehow prime the fuel system to get it going? Today I had a similar experience to the club car fuel problem with my John Deere mower. I wanted to see if the mower would start after it had been sitting all winter. There was no fuel in the lines and I could see the filter was empty. No matter how much I cranked the engine over it would not pump fuel. I thought this was the curse of the fuel pumps! It wasn't until I sprayed starting fluid into the carb and the engine fired up that it finally started pumping gas.

I've had the fuel pump from the John Deere which I now know works, installed on the club car and it still didnt run.
Xtreme Cartz is offline   Reply With Quote
Old 02-16-2014, 10:38 PM   #10
tacomaman
Not Yet Wild
 
tacomaman's Avatar
Club Car
 
Join Date: Feb 2012
Location: York,SC
Posts: 44
Default Re: Starting issues 94 DS

Sometimes,I will prime them to get the fuel going quicker. All I do is take the fuel cap off.....put a rag on the hole and blow a little compressed air in until I see it go into the filter that's closest to the carb.
tacomaman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
G8 with some starting issues Gas Yamaha
G16 starting issues Gas Yamaha
KF 82 Starting issues Gas Club Car
97 TXT Starting issues Gas EZGO
G2 have starting issues Gas Yamaha


All times are GMT -5. The time now is 05:01 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.