lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-14-2009, 02:44 PM   #1
hugger73hatch
Not Yet Wild
 
Join Date: Jun 2009
Posts: 2
Default 93 Club Car Will Not Start

Been working on my dad's 93 Club Car and can't get it to start. Have replaced coil and solenoid and has no spark . Could it be the ignitor? How do I test it? Any help would be greatly appreciated.
Thanks!
hugger73hatch is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-22-2009, 08:47 AM   #2
silver77
Not Yet Wild
 
Join Date: May 2009
Posts: 7
Default Re: 93 Club Car Will Not Start

i just put in a new coil for a 97 up it has both coil and ignotior in it. That take out the guess work. I got it on ebay for 40 bucks with shipping and that sloved my problems. Its a pain to change it would be easer to pull the motor but i did it with out pulling. Hope this helps!
silver77 is offline   Reply With Quote
Old 06-23-2009, 10:56 PM   #3
hugger73hatch
Not Yet Wild
 
Join Date: Jun 2009
Posts: 2
Default Re: 93 Club Car Will Not Start

Got it figured out so thought I would let others know in case they were having the same problem. It was actually the rev limiter grounding itself out. I would recommend anyone having a no spark issue to try this first, as it is the easiest thing to do.

Take the bolt out of the rev limiter bracket that holds the ground wire (brown). Tape off the ground with electrical tape and see if it fires. If it does it is the rev limiter. That thing is like $200, so I'm not going to worry about replacing it right now.

I would also recommend when you do this to disconnect the fuel line or drain the gas as when I checked the oil I discovered it had a lot of gas in the oil from pumping gas into the cylinder and running down beside the rings. I drained the oil and the filter and drove it for like 5 minutes and no more gas in the oil. I am going to get a new filter tomorrow and change the oil again. You would think I would have thought about disconnecting the fuel before, but oh well.
hugger73hatch is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Club Car won't move, but does start Electric Club Car
88 Club car won't start Gas Club Car
1991 club car will not start Gas Club Car
club car will not start Gas Club Car
1993 Club Car won't Start Gas Club Car


All times are GMT -5. The time now is 11:19 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.