lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 03-09-2011, 11:24 PM   #1
lilpurks
Not Yet Wild
 
lilpurks's Avatar
Club Car
 
Join Date: Nov 2010
Location: Frederick Md
Posts: 11
Default generator not charging!

help! i have this 2001 club car fe350. its a bobcat pioneer if that makes a difference.

My generator just recently stopped charging the battery. starts fine, just discarges the battery when running it.

i made the mistake of throwing parts on it first.

first i replaced the voltage regualator, no difference.

so next i grounded the field terminal on the generator (one with small yellow wire) with the cart running and still only had 11volts at the battery. no difference at any rpm

every now and then for about 30sec or so the gererator WILL charge normal (14-15 volts) but dies out to only 1.6v or less from the output side. ( big white cable on generator) and there is no difference when wiggling/pulling any of the wiring

so next i replaced the brushes and while i had it apart i checked for continuity on all the brush holders to the terminals on the generator and made sure there was none shorting to ground. all good

i reinstalled the unit with the new brushes. still no difference. could it be the armiture? or what am i missing? thanks to all who reply, this is my first post!
lilpurks is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 03-09-2011, 11:35 PM   #2
pachanga90
I Refuse To Get Stuck!!!
 
pachanga90's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Hilton,NY
Posts: 5,426
Default Re: generator not charging!

I would pull the Generator and have it tested.If it tests good,check your wiring for a bad/loose connection.Start at the battery +/- and follow all thru the cart back to the Gen.Hope this helps.
pachanga90 is offline   Reply With Quote
Old 03-10-2011, 03:14 PM   #3
Land Owner
Gone Wild
 
Land Owner's Avatar
Club Car
 
Join Date: Mar 2010
Location: Mims, FL
Posts: 217
Default Re: generator not charging!

I was going to say it could well be the battery, but low charging may be the real problem, as you have discovered.
Land Owner is offline   Reply With Quote
Old 03-10-2011, 08:31 PM   #4
lilpurks
Not Yet Wild
 
lilpurks's Avatar
Club Car
 
Join Date: Nov 2010
Location: Frederick Md
Posts: 11
Default Re: generator not charging!

update. i was about to pull the generator off again and take it to go get tested but i just to be sure double checked the regulator by removing the yellow field wire and grounding that terminal and it charged... therefore the generator is good. so i either have a faulty new regualtor or a wiring issue.
lilpurks is offline   Reply With Quote
Old 03-10-2011, 08:53 PM   #5
pachanga90
I Refuse To Get Stuck!!!
 
pachanga90's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Hilton,NY
Posts: 5,426
Default Re: generator not charging!

If you full-field the connector at the regulator,this will test the regulator and wiring.If it charges when jumped,then regulator is bad.
pachanga90 is offline   Reply With Quote
Old 03-24-2011, 07:58 AM   #6
lilpurks
Not Yet Wild
 
lilpurks's Avatar
Club Car
 
Join Date: Nov 2010
Location: Frederick Md
Posts: 11
Default Re: generator not charging!

well i sent back my new regulator as defective. hopefully the new one will be here soon.
lilpurks is offline   Reply With Quote
Old 03-24-2011, 08:49 AM   #7
jcurrie69
Not Yet Wild
Mixed Breed
 
Join Date: Nov 2010
Location: PEI canada
Posts: 19
Default Re: generator not charging!

I've had several new regulators turn out to be bad. Hopefully another one will work for you.
jcurrie69 is offline   Reply With Quote
Old 03-24-2011, 09:19 AM   #8
rose88
Gone Wild
 
rose88's Avatar
Club Car
 
Join Date: Apr 2010
Location: West Tennessee
Posts: 1,180
Default Re: generator not charging!

I am having the same issue on a customers cart. Fixing to test it and will post what I find.

rose88 is offline   Reply With Quote
Old 03-24-2011, 09:43 AM   #9
shadowman
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: generator not charging!

Quote:
Originally Posted by jcurrie69 View Post
I've had several new regulators turn out to be bad. Hopefully another one will work for you.

ditto, not uncommon at all to get a new bad V.R......................
shadowman is offline   Reply With Quote
Old 03-24-2011, 10:09 AM   #10
rose88
Gone Wild
 
rose88's Avatar
Club Car
 
Join Date: Apr 2010
Location: West Tennessee
Posts: 1,180
Default Re: generator not charging!

Ok removed the yellow wire from generator and jumped the DF & A2 and it would not quit charging, went up to 18.3 so I quit. I believe I have a bad Regulator?

rose88 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Starter/Generator not charging. Gas EZGO
Charging while driving w/ generator via charger Electric Club Car
charging with a generator Electric EZGO
generator not charging Gas Club Car
Charging your cart using a generator Electric EZGO


All times are GMT -5. The time now is 08:15 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.