lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 02-22-2008, 03:50 PM   #11
cupcake
Not Yet Wild
 
cupcake's Avatar
 
Join Date: Feb 2008
Posts: 16
Default Re: wont run with airbox

Forgive me for being stupid. But if the main jet is too small for the k&n then would it not also be too small to run decent with no airfilter at all?

Oh sorry for the avatar, didnt think it was in that poor of taste.
cupcake is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 02-22-2008, 03:56 PM   #12
TheNewGuy
Admin/Moderator
 
TheNewGuy's Avatar
Yamaha
 
Join Date: Dec 2006
Location: Ohio
Posts: 17,836
Default Re: wont run with airbox

Quote:
Originally Posted by cupcake View Post
Forgive me for being stupid. But if the main jet is too small for the k&n then would it not also be too small to run decent with no airfilter at all?

Oh sorry for the avatar, didnt think it was in that poor of taste.

Yes, that is why I thought maybe your jet was too big already.

If you need all that air flow to make it run right, then you have to be getting
LOTS of gas.

Check to make sure your choke is opening all the way.

TheNewGuy is offline   Reply With Quote
Old 02-22-2008, 04:42 PM   #13
spriddle
Admin
 
spriddle's Avatar
Yamaha
 
Join Date: Dec 2006
Location: TN
Posts: 101,639
Default Re: wont run with airbox

Also, make sure the throttle on the carb. is opening all the way when you press the pedal.

spriddle is offline   Reply With Quote
Old 02-24-2008, 11:34 PM   #14
cupcake
Not Yet Wild
 
cupcake's Avatar
 
Join Date: Feb 2008
Posts: 16
Default Re: wont run with airbox

Choke is completly open when open, throttle plates works full travel.
cupcake is offline   Reply With Quote
Old 02-25-2008, 03:26 PM   #15
hotwatermusic
Gone Wild
 
hotwatermusic's Avatar
 
Join Date: Dec 2007
Location: lake county FL
Posts: 327
Default Re: wont run with airbox

reason i said about the main jet was because my k&n was not working so i made the jet larger now it runs like a champ. this is also the reason i thought yours might have been clogged. mine was letting the engine get about half throttle then bogging down. i could be wrong thats just what went on with my cart. and i liked the avatar. who wouldn't?
hotwatermusic is offline   Reply With Quote
Old 02-25-2008, 05:23 PM   #16
Yamaha4life
The Overposter!
 
Yamaha4life's Avatar
Yamaha
 
Join Date: Nov 2007
Location: Dixie
Posts: 1,586
Default Re: wont run with airbox

Hey cupcake I also like your avatar...

Back when I had my stock G2 engine still in mine i couldnt get it run at all with the airbox on there. I just took the carb off and cleaned it out really good and got a brand new airbox and it ran like a champ...
Yamaha4life is offline   Reply With Quote
Old 02-25-2008, 09:12 PM   #17
cupcake
Not Yet Wild
 
cupcake's Avatar
 
Join Date: Feb 2008
Posts: 16
Default Re: wont run with airbox

Exactly abouyt the avatar but when I logged back in later that dauy it had been removed, I figured that waqs a hbint it was apprieciated.
cupcake is offline   Reply With Quote
Old 02-27-2008, 12:28 PM   #18
bmyers621
Not Yet Wild
 
Join Date: Feb 2008
Posts: 6
Default Re: wont run with airbox

I have a yamaha G9 gas cart and I had the same problem. I tried everything. I rebuilt the enigine, changed out the carborator, spark plug, coil, and excelorator. And this is how I fixed it. I wish everything was this simple.

What's Causing it:
The backfiring is usually caused by the carburetor throttle plate being slightly open, which allows gas to flow into the cylinder before the ignition system comes on to produce a spark. For this system to work
properly, the spark should be in the cylinder before the gas.

This is probably happening because the accelerator cable is out of adjustment at the carburetor throttle plate.

How to Fix it:
With the key off and the seat removed, press the accelerator pedal down. You should hear a low, almost inaudible "click" from the accelerator micro switch before the accelerator cable causes the carburetor throttle plate to open. The cable may move through the plate, but not actually move it. Be sure the micro switch clicks before the plate actually moves, not the cable. If this isn't set correctly, loosen the cable nut behind the plate with an
Allen wrench. Press the throttle plate lever all the way closed and compress the nut and spring (if applicable) against the plate and tighten nut in place. Try the test again until the adjustment is right.
bmyers621 is offline   Reply With Quote
Old 03-03-2008, 11:54 PM   #19
cupcake
Not Yet Wild
 
cupcake's Avatar
 
Join Date: Feb 2008
Posts: 16
Default Re: wont run with airbox

A) my cable adjustment is fine, and 2) even if it wasent it would make it not run with the airbox installed.
cupcake is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
Cart wont start Gas EZGO
93 36V cart wont move Electric Club Car
club car wont go Electric Club Car
she wont go so EZ Electric EZGO
Rear clutch wont engage Big Block Talk!


All times are GMT -5. The time now is 06:17 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.