lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO > Lithium EZGO


Post New Thread  Reply
 
Thread Tools Display Modes
Old 11-30-2020, 04:22 PM   #1
jhornbr225
Not Yet Wild
E-Z-GO
 
Join Date: Aug 2015
Posts: 46
Default Starting my EZGO Marathon Lithium build.

Finally getting around to posting my build.

I have a 1993 (I believe) Marathon 3 Wheeler. I picked it up about 5 years ago, put a set of 6, 6V Trojans in it, and the wife and I use it around the yard. We have 5 Acres, pretty flat. Mostly I got it for running around the yard, and running to the neighbors the back way. Since it's electric and silent, it's great for going over to the neighbors, and if we leave late at night, there's no gas engine running to wake anybody up. Also, if the wife uses it, and she has an adult beverage, she's not on the road with her car, to go 700 feet.

We dubbed it "Marty" as in, "Marty the Party Cart". Its no looker, but it gets the job done.

As well as new batteries 5 years ago, I installed a 36V-12V power converter, and added some LED headlights.

Over the past year, it's started to need water in the batteries. No big deal, but here late in the fall, the wife left the key on a couple times, which I thought killed the batteries. When it would move, you would push the pedal down, and all the sudden it would JUMP at full speed. A little research led me to believe the batteries were shot. Then it got to the point it wouldn't move at all.

I decided to go Lithium, and upgrade to 48V (ish). I picked a list of parts, and got them ordered. So far:

Alltrax 48500
SW200 Main Contactor
SW202 Reversing Contactors
Precharge Resistor and Diodes
Qty 4 5S BMW 75Ah batteries
Qty 2 4S BMW 75Ah batteries (All of these will parallel together to make a 150Ah 14S Battery.) I got these from BatteryHookup.
14S BMS from BatteryHookup. (It's supposed to have low temp cutoff)
Parts to build the LV and HV monitoring circuit (ala Sergio)
10A 14S Charger
35A DC to DC converter
New Radio
Plum Quick Widowmaker Motor

I had done a little troubleshooting, and found that the reason it wouldn't move on it's own was that I believe the original Curtis controller gave out. I jacked up the rear end, and used 2 of the batteries (12V), through the reversing switch, and the motor turned. I also found out that I have the Blue GE motor, which from my research is 36V only, and not as strong as the AMD motor.

I have pulled all the batteries out, and I see I have some cleanup and painting to do. Yesterday I pulled the motor to confirm it's the 19 Spline. I also played with battery layouts to minimize the fabrication needed. I think by moving the pot box around, and relocating a diagonal brace to give me 1/4" more room, I think they will all fit. Once the diagonal brace in the last pic is moved, that askew battery will sit flat.

I think so far the biggest challenge will be top-balancing the batteries, and hooking good sized wires to actually parallel up the cells. The busbars in these batteries are welded in, so my options for paralleling up cells will require creativity.
Attached Images
File Type: jpg IMG_20201115_182911632.jpg (111.0 KB, 0 views)
File Type: jpg IMG_20201129_190826736.jpg (185.5 KB, 0 views)
File Type: jpg IMG_20201129_190930751.jpg (161.6 KB, 0 views)
jhornbr225 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 11-30-2020, 04:51 PM   #2
jhornbr225
Not Yet Wild
E-Z-GO
 
Join Date: Aug 2015
Posts: 46
Default Re: Starting my EZGO Marathon Lithium build.

Here's the batteries.

I was originally thinking of cutting a slit in the busbar, and then bending it up to make a tab that I could drill a hole in. That does have the possibility of creating a flimsy, bending tab. I also have to be careful of how close I get to the main terminals for the pack. Battery Hookup sends some very nice cables with plugs on them to tie the batteries in series, or to make connections. Of all these plugs, I have 5 that are 90 plugs. Those will come in handy, especially on the two 4S batteries, where space is a little tight. Now I'm thinking of cutting a 1/2" slit on each side of the "arch", then sliding a plate that has a couple holes in it through the slit. Then I can take an identical plate from the top, and "clamp" down onto the arch. With that method, I am cutting parallel to the cell, and not down into it. Less chance of an error causing a big problem. Attached is a rough sketch of my idea.

These plates wont be the primary current path, they'll be like a busbar extension, so that essentially I'll have a 14S4P battery pack. I'll also attach my balance leads to those tie points as well. Each individual battery is already either a 5S2P or a 4S2P respectively.

When ordering batteries, my original plan was to use two completely parallel strings, with two BMS units. After some more reading, I have decided to go with just one BMS, and parallel up the cells. That avoids some nasty problems. After reading this document, I changed my mind.

https://www.orionbms.com/manuals/pdf...el_strings.pdf

i know this will present unique challenges compared to the Leaf packs, but that's OK.
Attached Images
File Type: png bmw4s_1_1024x1024@2x.png (535.1 KB, 0 views)
File Type: png bmw5s_1_1024x1024@2x.png (554.3 KB, 0 views)
Attached Files
File Type: pdf 4S mods Rev2.pdf (54.0 KB, 0 views)
jhornbr225 is offline   Reply With Quote
Old 12-11-2020, 06:19 PM   #3
jhornbr225
Not Yet Wild
E-Z-GO
 
Join Date: Aug 2015
Posts: 46
Default Re: Starting my EZGO Marathon Lithium build.

My father-in-laws co-worker is a welder, and they stopped by today to look at Marty and see about the welding required to get the batteries to fit. It actually looks like the one bay where I thought the whole diagonal brace needed moved, has already had a repair, which moved the mounting point of the top of the brace closer to the front of the cart. Although it was fine with the FLA batteries, the 4S lithium is just slightly longer. It's the picture of the single battery hole in the first post. We have an appointment next week to load the cart on the trailer, and take it to his shop.

He was thinking of putting some heat on the brace, and trying to bend it. I think the mounting point is just too far forward. I'm thinking we'll just hit it with the angle grinder on that repaired weld to break it loose, move it back a little, and re-weld it.

We hit it with a hammer today and bent it a little. Now the battery fits down in the slot, but with that edge being too far forward, the battery was sitting too high.

Also by going with the battery layout pictured in the first post, and moving the pot box, I'll be able to keep the factory throttle linkage. That's a win.
jhornbr225 is offline   Reply With Quote
Old 12-17-2020, 04:19 PM   #4
jhornbr225
Not Yet Wild
E-Z-GO
 
Join Date: Aug 2015
Posts: 46
Default Re: Starting my EZGO Marathon Lithium build.

I loaded up Marty the other day, and took him over to the welder's house. We ground around the brace, and knocked it loose from the frame. He was then able to weld it back a little further and the battery now fits where it is supposed to. There was also a 90 bracket going to the side fender from the battery tray that was broken loose. So we patched that up as well.

I've been doing some thinking on the batteries, and how to parallel them up. I've drawn it up in CAD, and determined the best rotation of the batteries for easier wiring.

I've also been doing some research into capacitive discharge stud welding. The existing busbars inside the batteries are about .050" thick, from what I can measure with my metal calipers, being careful not to short any cells. If I could have someone CD weld some studs onto the busbars, then I would not have to do any dremel work. If I had some 1/4"-20 studs welded to the existing busbars, I could just run the cables in between the cells to parallel them up. That would save a bunch of time and hassle.

I've reached out to a few places and friends locally to see if they have the capability, or know someone who has the equipment to do that. First I contacted a local fabricator house. I've had them do some work for me before. I know they have a laser to cut metal, but I'm not sure they have a CD stud welder. I also reached out to a friend who runs an auto body shop. I'm sure he's got a small one to pull dents, but I'm not sure if his would be large enough to land a 1/4-20 stud. Lastly I contacted my cousin who owns an HVAC repair business. He runs ductwork, but again, I'm not sure if he would have anything big enough.

Another crazy thought I had today was to not parallel them up at all. Basically have two separate sets of batteries, each with their own BMS. The negative of each set could tie together at the Alltrax, but there would only be one positive cable down to the fuse, but it would be long enough to reach the positive side of either string. I did purchase two BMS's to start with. Since the BMW connectors are so easy to plug in and out, I could have one set of batteries be active, and have the other set be idle/able to charge. If you are running the first set of batteries, and they get low, it would be easy to flip the seat up and move the plug over to the other set of batteries. In that case, two voltmeters in the dash would be nice, one for each set. Also some relay logic would be required to make sure the current active set of batteries/BMS combo would be the one that could shut off the keyswitch in the event of an undervoltage. I would also only want the voltmeters to light up if the keyswitch was on. But an undervoltage event shouldn't cut off the voltmeters either, just the Alltrax controller. There are a few negatives to that method though. Having a second set of batteries, I'd have to make it easy enough so that the wife would be able to swap the cable. Even if the idle set needed charged, it's still capable of releasing a ton of energy in the event of a mishap. Also I'd be carrying around 96 extra pounds of dead weight.
jhornbr225 is offline   Reply With Quote
Old 12-19-2020, 08:01 PM   #5
jhornbr225
Not Yet Wild
E-Z-GO
 
Join Date: Aug 2015
Posts: 46
Default Re: Starting my EZGO Marathon Lithium build.

I decided to just go ahead and drill holes and mount aluminum plates.

It takes some time, as all the parts are custom. To fit 10-32 nuts under the humps, I have to file them down to be narrow, and then put a 45 on each side. The nice thing is that under each "hump" in the busbar, it is solid plastic, so the nut slides into place easily. I then drill a hole in the hump, being careful not to go too deep. I slide a piece of paper into the hump so catch any debris, and do a lot of vacuuming. I worked on it Friday afternoon, and all day Saturday, and I am pleased to say I'm half done! Yay! I've done one of the 4S batteries and 2 of the 5S. It took longer to do the first battery, as I was refining my method. Today I made all the nuts at one time, then I made all the plates. Then I drilled the humps, and assembled it. Then I cut the cover so that I could snap it back into place.

Tomorrow I'll continue, but I can't be sure I'll finish. And even with the plates in place, I'm still able to use the BMW plugs and get them to plug in and out. I can even use the straight plugs. It's only the 4S batteries that give a problem with space, as the 5S ones dont require a plate so close to where those plug in.
Attached Images
File Type: jpg IMG_20201218_164418135.jpg (77.6 KB, 0 views)
File Type: jpg IMG_20201218_164445313.jpg (169.2 KB, 0 views)
File Type: jpg IMG_20201218_164923508.jpg (135.4 KB, 0 views)
File Type: jpg IMG_20201218_193253297.jpg (135.8 KB, 0 views)
jhornbr225 is offline   Reply With Quote
Old 01-19-2021, 01:05 PM   #6
jhornbr225
Not Yet Wild
E-Z-GO
 
Join Date: Aug 2015
Posts: 46
Default Re: Starting my EZGO Marathon Lithium build.

I did work on the batteries the following day, and got four out of the six done. I ran out of aluminum bar, so I had to get some more. I did finish making all the nuts I needed. That was the time consuming process.

I see that the new motor arrived. Looking forward to getting going on this again.
jhornbr225 is offline   Reply With Quote
Old 04-20-2021, 09:21 PM   #7
jhornbr225
Not Yet Wild
E-Z-GO
 
Join Date: Aug 2015
Posts: 46
Default Re: Starting my EZGO Marathon Lithium build.

Well, some time has passed, and it's starting to get warm, so the motivation to get this project going has returned.

I discovered that trying to make a 14S string with the way the batteries were was going to be too difficult. So I went back into fabrication mode, and added plates and studs to the 2 remaining plates in each battery. That way I will not have to do tie points that are not mounted to a battery. I think that will make things more stable. Even if I don't use any of the plugs that came with the batteries, that's fine.

I went shopping for 2AWG wire and crimp terminals the other day. At my local electrical supply houses, each 2AWG crimp ring terminal is about $4. I need 40 of those just for the batteries themselves, not to mention some other sizes for the motor and the contactors. I did find 2AWG welding cable for $1.59/foot. I ordered the crimp connectors on Amazon, much cheaper that way.

Unfortunately there is a problem with my detached garage workspace. I noticed that the insulation panels on the ceiling were developing gaps between them. I then noticed that the roof in the middle of the building is sagging, and the garage door rollers are almost all the way out of the holders as the door raises. Also the chimney for the wood burner is leaning. I called a contractor to come out and look at it and give me an estimate, and he says the roof trusses have failed. The top of the south wall is leaning out, and the horizontal part of the trusses has separated. I'm now in the process of cleaning the building out so that it can be worked on. Not to mention there are 51 solar panels on the roof that need removed before any work can start.

Never a dull moment.
jhornbr225 is offline   Reply With Quote
Old 07-17-2021, 11:57 AM   #8
jhornbr225
Not Yet Wild
E-Z-GO
 
Join Date: Aug 2015
Posts: 46
Default Re: Starting my EZGO Marathon Lithium build.

I got a few things done on the build the other day.

The contractor came and built a wall down the middle of the garage, and braced the south wall so it won't lean out at the top any more than it already is, so now I feel that it won't collapse with me inside

I installed the new motor. What was supposed to be a quick easy task took a little longer than expected. For some reason the bolt circle wasn't quite the same size as my original motor. I could get two bolts in, but not the third. I tried rolling it around to all the possibilities. (A little difficult with the handle on the Plum Quick.) Finally I decided to just enlarge one of the holes on the axle, as it was just a few thousandths of an inch off. I covered the shaft going into the transaxle, and drilled one of the holes just slightly larger.

I then played with the placing of the existing metal bracket that holds all the original stuff, and where to mount the new stuff.

I'm moving the bracket over to the driver's side of the cart, due to the placement of the batteries and the location of the throttle linkage. I'm moving the throttle potentiometer box and it's linkage to the outside of the bracket as opposed to the inside. I'm mounting the Alltrax on the inside of the bracket, facing forward, with the fan towards the ground. That will leave be space on the backside of the bracket to mount both contactors. The main contactor down low, and the reversing contactor up high. Two of the mounting holes in the Alltrax will be drilled through the mounting bracket so that the reversing contactor can mount directly to the bracket on the backside of those holes. I'll have to space out the throttle linkage to meet up with the existing throttle rod coming back from the pedal. I'm sure it will all make more sense once I get it installed and take a picture.

I ran over to the local Bolt and Nut House yesterday and picked up hardware. I was almost out of 1/4-20 nyloc nuts, and didn't have right bolt lengths to mount this stuff anyway.

I may be going into overkill, but I've ordered the parts for an emitter follower voltage regulator. I'm a little worried since the max voltage of the pack can go as high as 58.8V. I really only plan to charge to 56.7V, but I don't want to overvolt the coils in the contactors. I've ordered a 51V Zener and an MJE3055T transistor. Those components, along with a resistor, should hold my voltage at 50.3V for the contactors, which is +4.7% of the contactor rated voltage. The MJE3055's are 10A, so that should be plenty of amps. I've also decided not to add all the parts for Sergio's Over/Under voltage protection, as his circuit uses 3 relays, two of which are related to having an on-board charger, which I don't have. So I only need one relay. I'll put the parts for my voltage regulator in the box with my BMS and that one relay.
jhornbr225 is offline   Reply With Quote
Old 07-19-2021, 03:42 PM   #9
jhornbr225
Not Yet Wild
E-Z-GO
 
Join Date: Aug 2015
Posts: 46
Default Re: Starting my EZGO Marathon Lithium build.

My parts for my voltage regulator arrived Sunday. I was surprised to see surface mount parts in the bag. I had ordered MJE3055T, which is a TO-220 package transistor. The sticker on the envelope said it was a transistor, but when I searched the actual number on the surface mount device, I found out that it was a MOSFET. That won't work. Amazon has given me a credit for the improper devices, and I don't have to ship them back, but I still need some MJE3055T's. I left some feedback to the seller, but have not heard anything yet.

I put a couple stubs of 1/4-20 threaded rod up through the original framework of the battery tray. This will hold the battery in front of the controller/contactor bracket in place. I also drilled for mounting the bracket.

I drilled holes in the bracket itself to mount the main contactor down low, and the reversing contactor up high. The main contactor is mounted high enough so that if the bottom of the cart hits the ground, on a high center situation, it won't damage the contactor.

Today I managed to order some of the Bluetooth interfaces for my BMS's, from Battery Hookup, as I failed to order them when I placed my original order, and lately they have been out of stock.

Next step is get the throttle pot and switch mounted in the proper position. Also I need to mount the fuse, which is going between the throttle rod and the battery. With the battery in front of the bracket held steady, there is room under it to mount brackets to hold the fuse.
Attached Images
File Type: jpg IMG_20210718_154845126.jpg (101.5 KB, 0 views)
File Type: jpg IMG_20210718_154852385.jpg (122.8 KB, 0 views)
jhornbr225 is offline   Reply With Quote
Old 07-20-2021, 11:17 AM   #10
bronsonj
Gone Wild
 
bronsonj's Avatar
E-Z-GO
 
Join Date: Jan 2013
Location: Saint Petersburg, FL
Posts: 1,983
Default Re: Starting my EZGO Marathon Lithium build.

Wow, you've been busy! Looking good!
bronsonj is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO > Lithium EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Lowered 97' EZGO TXT lithium 36v to 48v build On Road Golf Carts!
ezgo Marathon Starting Gas EZGO
Starting my lithium build All things Lithium
Ezgo marathon starting without pedal Gas EZGO
I will be starting my ezgo build soon Lifted Golf Carts


All times are GMT -5. The time now is 07:53 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.