lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-01-2022, 07:43 AM   #1
wingnut2000
Gone Wild
 
wingnut2000's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Georgia
Posts: 459
Default 15 RXV Trouble Shooting-PLEASE HELP so i Can use for Holiday Weekend

I have a 2015 RXV with a lithium battery from bigbattery.com and have been running on it for a few months now. I recently took out the digital plug and play state of charge meter and replaced with a newer meter that has a shunt but have not calibrated it yet. I have drove the cart several times since installing it with no issues.

Yesterday my step son broke down in the neighbor hood. No power to the meter, lights or anything. I checked for loose connections under the seat and behind ignition switch. After moving stuff behind the key switch the cart worked and went for 100 yards or so. I played with it again and again but couldn't get anything to power back up. After several times of plugging and unplugging the #3 plug under the seat into the #1 plug and it finally unlocked the brake to roll it and I decided I would try and move wires back and drive it but it only went about 50yds then it locked up again. I tried again numerous times moving plugs under seat to get brake to unlock and checking for loose connections and finally I kept trying the plugs and got the brake to unlock and towed it home.

I thought maybe it was just a dead battery but I found this hard to believe. Thinking son hadnt been plugging the battery up after using and since my monitor isn't calibrated that maybe this was actually the case. When I got home with it but nothing happened when i plugged it up. The charger doesn't make the light flash next to receptacle and through the app for my summit charger it doesnt detect that its even plugged up.


Any suggestions? is this a motor brake issue? solenoid? or battery doesnt have enough volts for charger to recognize it?
wingnut2000 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-01-2022, 08:17 AM   #2
Volt_Ampere
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 5,104
Default Re: 15 RXV Trouble Shooting-PLEASE HELP so i Can use for Holiday Weekend

Measure the battery voltage right at the battery. The BMS may be shutting it down.
Volt_Ampere is offline   Reply With Quote
Old 07-01-2022, 03:01 PM   #3
wingnut2000
Gone Wild
 
wingnut2000's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Georgia
Posts: 459
Default Re: 15 RXV Trouble Shooting-PLEASE HELP so i Can use for Holiday Weekend

Well when I was working on cart yesterday i took off charger receptacle wire from battery and now itís hooked up and seems to be charging and it is passing checks with controller when turning key on. Guess it just ran completely dead.
wingnut2000 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Trouble shooting help please Electric EZGO
Trouble shooting 96 txt no go Gas EZGO
trouble shooting help G16 Electric Yamaha


All times are GMT -5. The time now is 02:43 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.