lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 11-16-2021, 07:41 AM   #1
Kevin63
Not Yet Wild
 
Join Date: Nov 2021
Posts: 6
Default No Spark on 2002 Ezgo TXT

I have replaced every component on the ignition system and still no spark, new coil, igniter, solenoid, regulator, spark plugs, pulse coil. I ran an extra ground wire from the battery to engine. I even made an external wiring harness that bypassed the original wiring between igniter and engine. When testing the pulse coil, the original checked 19 ohms and the manual says it should check around 400 - 500 ohms. The aftermarket pulse coil I'm using checked 200 ohms. Any ideas?
Kevin63 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 11-16-2021, 08:05 AM   #2
crash12888
Gone Crazy
 
Join Date: Jan 2007
Location: Chesterfield, Va
Posts: 5,908
Default Re: No Spark on 2002 Ezgo TXT

I have to ask, are the replacement parts aftermarket or OEM?
Did you keep all of your OEM parts?
crash12888 is offline   Reply With Quote
Old 11-16-2021, 10:20 AM   #3
Kevin63
Not Yet Wild
 
Join Date: Nov 2021
Posts: 6
Default Re: No Spark on 2002 Ezgo TXT

Replacement parts are aftermarket and I did save my old ones.
Kevin63 is offline   Reply With Quote
Old 11-16-2021, 06:25 PM   #4
trig123
Gone Wild
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: Out there somewhere
Posts: 2,249
Default Re: No Spark on 2002 Ezgo TXT

Quote:
Originally Posted by Kevin63 View Post
I have replaced every component on the ignition system and still no spark, new coil, igniter, solenoid, regulator, spark plugs, pulse coil. I ran an extra ground wire from the battery to engine. I even made an external wiring harness that bypassed the original wiring between igniter and engine. When testing the pulse coil, the original checked 19 ohms and the manual says it should check around 400 - 500 ohms. The aftermarket pulse coil I'm using checked 200 ohms. Any ideas?
Put the original pulser coil back on it. The manual states on the pre mci engine it should ohms from 19-21. I think you are looking at the MCI in the manual. A 2002 TXT should have the pre mci engine. Yours is good.
Take a picture of the ignitor you removed and post it here.
trig123 is offline   Reply With Quote
Old 11-18-2021, 07:18 AM   #5
Kevin63
Not Yet Wild
 
Join Date: Nov 2021
Posts: 6
Default Re: No Spark on 2002 Ezgo TXT

Igniter appears to be an aftermarket. Have not had time yet to install the original pulse coil.
Attached Images
File Type: jpg igniter.jpg (197.9 KB, 0 views)
Kevin63 is offline   Reply With Quote
Old 11-18-2021, 09:07 AM   #6
trig123
Gone Wild
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: Out there somewhere
Posts: 2,249
Default Re: No Spark on 2002 Ezgo TXT

Quote:
Originally Posted by Kevin63 View Post
Igniter appears to be an aftermarket. Have not had time yet to install the original pulse coil.
Yep, that is a true aftermarket ignitor. Some work and some don't. Wish I could tell you where to find an OEM . Ezgo no longer sells them.
trig123 is offline   Reply With Quote
Old 11-18-2021, 11:25 AM   #7
crash12888
Gone Crazy
 
Join Date: Jan 2007
Location: Chesterfield, Va
Posts: 5,908
Default Re: No Spark on 2002 Ezgo TXT

Quote:
Originally Posted by trig123 View Post
Yep, that is a true aftermarket ignitor. Some work and some don't. Wish I could tell you where to find an OEM . Ezgo no longer sells them.
Trig or anyone have an OEM they could check for original numbers? Did Ezgo make these or source them from some where else?
I know someone just posted info about an obsolete coil the was used on a motorcycle or scooter that is still available.
crash12888 is offline   Reply With Quote
Old 11-18-2021, 07:38 PM   #8
trig123
Gone Wild
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: Out there somewhere
Posts: 2,249
Default Re: No Spark on 2002 Ezgo TXT

Quote:
Originally Posted by crash12888 View Post
Trig or anyone have an OEM they could check for original numbers? Did Ezgo make these or source them from some where else?
I know someone just posted info about an obsolete coil the was used on a motorcycle or scooter that is still available.
These ignitors were made by the same company that made the robbin engine. They are both made in Japan and were sold to ezgo.

Here is a picture of what an OEM ignitor looks like.

I have used a Denso coil from a snowmobile and it worked fine. I will include a picture of the one I have now. Much more spark than the cheap ones.

I don't trust these ignitors and coils people buy on amazon or ebay. Unless the ignitor looks like the one I showed its not OEM.
Attached Images
File Type: jpg Ezgo ignitor OEM.jpg (371.1 KB, 0 views)
File Type: jpg Coil .jpg (230.2 KB, 0 views)
trig123 is offline   Reply With Quote
Old 11-19-2021, 07:56 AM   #9
Kevin63
Not Yet Wild
 
Join Date: Nov 2021
Posts: 6
Default Re: No Spark on 2002 Ezgo TXT

I reinstalled the old pulse coil and gapped it to .030 and still no spark. I ordered a new one online from a golf cart supplier hoping this fixes the problem (pic attached of new igniter). Thanks for the help.
Attached Images
File Type: jpg Screenshot_20211119-063531.jpg (32.8 KB, 0 views)
Kevin63 is offline   Reply With Quote
Old 11-19-2021, 08:26 AM   #10
Cartmaster
British and proud
 
Cartmaster's Avatar
E-Z-GO
 
Join Date: Feb 2007
Location: United Kingdom
Posts: 1,204
Default Re: No Spark on 2002 Ezgo TXT

Do you also have a picture of the actual new igniter that you bought? That image you just showed is a stock image. Probably not the same item sent, as pretty much nobody has them anymore. They went out of production around 2014, and we have only been able to source old shelf stock and cloned aftermarket ones since. Now the old stock has pretty much run out, only the clones are available. I would try to find someone who has done an engine upgrade and has a used working old OEM one laying in there spares box.

Can I ask how much you payed for it and where it was bought from?
Cartmaster is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2002 EZGO: No spark.. and what is this mystery wire??? Gas EZGO
2002 GAS EZGO TXT - Cranks but won’t start; no spark Gas EZGO
No spark on 2002 txt Gas EZGO
2002 ezgo spark problems Gas EZGO
2002 ezgo intermittent spark Gas EZGO


All times are GMT -5. The time now is 06:14 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.