lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Star and Fairplay


Post New Thread  Reply
 
Thread Tools Display Modes
Old 01-21-2012, 07:39 PM   #1
08star
Not Yet Wild
Star
 
Join Date: Oct 2011
Posts: 7
Default Torque Issues

My Star cart just doesn't seem to have the torque it used to have. Power off the line is just terrible. The batteries are brand new so I am pretty sure that is not the issue however I don't know if it could be the motor or controller. It used to be a lot more peppy before the first set of batteries started to die so I know it is not due to it being 36 volts. It is all stock so maybe if anything is in need to be replaced an upgrade is in store.

any help is greatly appreciated.
08star is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Reply

Tags
star 36 volt
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Star and Fairplay


Thread Tools
Display Modes


Similar Threads
Thread Forum
New D&D Torque Motor (4:1) - Not Seeing 40% Torque Electric EZGO
powerdrive 2 issues and speed issues. Electric Club Car
Torque spring issues!! Gas Yamaha
g9 torque spring kit issues Gas Yamaha
Electric Torque vs Gas Torque Electric Club Car


All times are GMT -5. The time now is 01:55 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.