lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-10-2008, 02:22 PM   #1
tech00
Not Yet Wild
 
Join Date: Jul 2008
Posts: 6
Default 1995 EZGO troubleshooting ?

Got a 95 ezego that has started slowing down after about 15 min. of riding. Put a load tester on the batteries and all six tested good.Does any one have any troubleshooting tips on how and what I should check.I sprayed wd40 on the forward/reverse switch because it was kinda stiff ,don't know if this had anything to do with it or not.Up until this I could ride a Hour and half or longer.Don't know too much more to tell you . Thanks
tech00 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-10-2008, 03:35 PM   #2
EZ-GOnewild
Gone Wild
E-Z-GO
 
Join Date: Apr 2008
Location: Wichita, KS
Posts: 1,526
Cool Re: 1995 EZGO troubleshooting ?

Welcome tech00!
EZ-GOnewild is offline   Reply With Quote
Old 07-10-2008, 07:30 PM   #3
rusty
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,236
Default Re: 1995 EZGO troubleshooting ?

Welcome to the forum tech00......................
rusty is offline   Reply With Quote
Old 07-10-2008, 07:59 PM   #4
roady89
nimda
Club Car
 
Join Date: Jun 2007
Posts: 13,023
Default Re: 1995 EZGO troubleshooting ?

Read this, http://www.buggiesgonewild.com/elect...e-posting.html and then post your findings when your done.
roady89 is offline   Reply With Quote
Old 07-11-2008, 07:20 AM   #5
armandojudith@bellsouth.n
Not Yet Wild
 
Join Date: Jul 2008
Posts: 2
Default Re: 1995 EZGO troubleshooting ?

Hi to everybody thanks so much i look the forum its.....very interest ,i have problem with my car ez go dcs. electric 1995 is not runnig has new batteries new, solenoid , and nothing somebody know about this car thanks ,,,,
armandojudith@bellsouth.n is offline   Reply With Quote
Old 07-11-2008, 07:28 AM   #6
scottyb
Happy Carting
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 72,493
Default Re: 1995 EZGO troubleshooting ?

Quote:
Originally Posted by tech00 View Post
Got a 95 ezego that has started slowing down after about 15 min. of riding. Put a load tester on the batteries and all six tested good.Does any one have any troubleshooting tips on how and what I should check.I sprayed wd40 on the forward/reverse switch because it was kinda stiff ,don't know if this had anything to do with it or not.Up until this I could ride a Hour and half or longer.Don't know too much more to tell you . Thanks
Welcome TECH00
WD 40 is highly flamable on an open electrical contact switch. Had there been any of the common sparking that does happen with a F/R sometimes you could have had a fire.
What does the voltage read on yoour battery pack when you start out and when it starts to slow down?
scottyb is online now   Reply With Quote
Old 07-11-2008, 12:01 PM   #7
EZ-GOnewild
Gone Wild
E-Z-GO
 
Join Date: Apr 2008
Location: Wichita, KS
Posts: 1,526
Cool Re: 1995 EZGO troubleshooting ?

Quote:
Originally Posted by armandojudith@bellsouth.n View Post
Hi to everybody thanks so much i look the forum its.....very interest ,i have problem with my car ez go dcs. electric 1995 is not runnig has new batteries new, solenoid , and nothing somebody know about this car thanks ,,,,
Welcome armando, you may want to start your own thread from the home page.

Good luck!
EZ-GOnewild is offline   Reply With Quote
Old 07-11-2008, 03:52 PM   #8
tech00
Not Yet Wild
 
Join Date: Jul 2008
Posts: 6
Default Re: 1995 EZGO troubleshooting ?

Have not been able to read it after it slows down(been raining) but each battery has a reading or 6.4 v and one has 6.3 What terminals do I need to check for a total voltage reading. Should I disconnect the power and clean the wd40 off the f/r switch with some contact cleaner? Will post voltage radings tonite after it slows down.Thanks for the reply
tech00 is offline   Reply With Quote
Old 07-11-2008, 04:54 PM   #9
scottyb
Happy Carting
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 72,493
Default Re: 1995 EZGO troubleshooting ?

You can plug the voltmeter into the charger recepticle.
scottyb is online now   Reply With Quote
Old 07-11-2008, 06:46 PM   #10
tech00
Not Yet Wild
 
Join Date: Jul 2008
Posts: 6
Default Re: 1995 EZGO troubleshooting ?

Just got back from riding a little over 10 miles and it never slowed down.Seems to be working fine now.Voltage was at 6.46 on each battery(except one was 6.39)when I left and got a 6.28 on all six when I got back. Is that solenoid that is mounted on the box on the passanger side supposed to get kinda warm after a ride.Think it was labeled B2 and connected to f/r switch. Thanks for all the help guys. Great forum, glad to be a part of.
tech00 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
troubleshooting electric ezgo Electric EZGO
1995 EZGO electric suddenly won't budge Electric EZGO
Need Hel Asap 1995 Ezgo Electric 36v Electric EZGO
throttle problems on 1995 ezgo Electric EZGO


All times are GMT -5. The time now is 04:34 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.