lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-25-2016, 04:41 PM   #1
kymudder
Not Yet Wild
 
Join Date: Jul 2012
Posts: 29
Default Ezgo rxv runs but won't move

I have an 09 rxv on Saturday it started to slip a bit and by the end of the day it stopped moving completely. I had to tow it back to the house. Sunday I checked it before I went home from the lake and when u hit the pedal the belts move as should and the cart moves a little but makes a bad whining noise. It's never been abused and it's stock. The belts are only a few months old. Thanks for any input.
kymudder is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-25-2016, 08:40 PM   #2
StoveBolt
Gone Wild
 
StoveBolt's Avatar
 
Join Date: Feb 2008
Location: Brooklyn, Michigan "Home of M.I.S."
Posts: 3,554
Default Re: Ezgo rxv runs but won't move

Check for a stripped hub.
StoveBolt is offline   Reply With Quote
Old 07-31-2016, 01:19 PM   #3
kymudder
Not Yet Wild
 
Join Date: Jul 2012
Posts: 29
Default Re: Ezgo rxv runs but won't move

It makes a bad noise even when in neutral and it does move but it makes an awful noise. At one point it wouldn't move at all but I loaded it up today to bring home and I was able to drive it.
kymudder is offline   Reply With Quote
Old 08-01-2016, 06:51 AM   #4
StoveBolt
Gone Wild
 
StoveBolt's Avatar
 
Join Date: Feb 2008
Location: Brooklyn, Michigan "Home of M.I.S."
Posts: 3,554
Default Re: Ezgo rxv runs but won't move

How about with the belt off?
StoveBolt is offline   Reply With Quote
Old 08-01-2016, 07:01 PM   #5
kymudder
Not Yet Wild
 
Join Date: Jul 2012
Posts: 29
Default Re: Ezgo rxv runs but won't move

Noise goes away with belt off its coming from the driven clutch now if I can just get the *** thing off
kymudder is offline   Reply With Quote
Old 08-02-2016, 08:34 PM   #6
kymudder
Not Yet Wild
 
Join Date: Jul 2012
Posts: 29
Default Re: Ezgo rxv runs but won't move

Just to keep u posted the ramp boots where shot and the circling broke off the shaft in the clutch causing it to rub on the case and the spring to expand to far. So needless to say just ordered a new clutch
kymudder is offline   Reply With Quote
Old 08-02-2016, 08:43 PM   #7
StoveBolt
Gone Wild
 
StoveBolt's Avatar
 
Join Date: Feb 2008
Location: Brooklyn, Michigan "Home of M.I.S."
Posts: 3,554
Default Re: Ezgo rxv runs but won't move

StoveBolt is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
79 Gas EZGO runs but won't move Gas EZGO
04 Ez-Go runs but won't move???? Gas EZGO
My 87 ezgo runs but wont move? Gas EZGO
EZGO J402 motor runs but cart won't move Electric EZGO
97 Ezgo Motor runs but will not move Gas EZGO


All times are GMT -5. The time now is 12:11 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.