lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha
Electric Yamaha Electric Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 11-30-2022, 02:37 PM   #1
Rayferd
Getting Wild
 
Rayferd's Avatar
Club Car
 
Join Date: Aug 2015
Posts: 75
Default Yamaha Drive Controller issues

Hey yall.

I have a Yamaha drive with the moric controller. It came in with a bad controller. After replacing it the cart still isn't running, but does show some signs of life now, as the solenoid is cycling, and the speed sensor is functioning.

I suspect that the new controller is faulty also, even though I know that is rare. Has anone else experienced this?

What leads me to believe that is on the blue, and black wires to the throttle position sensor I am not getting a resting voltage, or an accelerator pressed voltage. I also checked any combination of the 3 wires and still no voltage. Continuity checks from the controller plug to the sensor all check good.

I also swapped the solenoid with a known good one for good measure.

Any help is appreciated,

Thanks!
Rayferd is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 11-30-2022, 04:49 PM   #2
ojo
Gone Wild
 
ojo's Avatar
E-Z-GO
 
Join Date: Sep 2020
Location: Germany
Posts: 1,321
Default Re: Yamaha Drive Controller issues

This is the test procedure for the TPS:
Attached Images
File Type: jpg Screenshot at 2021-10-31 13-28-36.jpg (116.4 KB, 0 views)
ojo is offline   Reply With Quote
Old 11-30-2022, 05:10 PM   #3
Volt_Ampere
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 5,747
Default Re: Yamaha Drive Controller issues

I have two drives and the Moric controller fails early and often. I have Alltrax controllers in both now and they are great - and you can connect them to a laptop to diagnose issues and tune the performance. I would send it back and get an Alltrax.
Volt_Ampere is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
Yamaha Drive 48v Issues Electric EZGO
Yamaha drive stereo amp issues, please help Gas Yamaha
Yamaha drive issues Gas Yamaha
Yamaha Drive wet brake issues Electric Yamaha
yamaha gas cart having drive issues Gas Yamaha


All times are GMT -5. The time now is 01:13 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.