lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-28-2011, 09:38 PM   #1
varieze
Not Yet Wild
 
Join Date: Sep 2011
Posts: 3
Smile engine runs irratic

1998 EZGO Gas 4 stroke twin cyl. stock engine.

engine will run great for a while and then acts like one spark plug fouls but new plugs do not help. However I noticed that with the lights on at night they go from white bright to normal and when they change to white bright the engine looses power and when they go back to normal the engine runs great. Is this a regulator problem and the jump in voltage is screwing with the ignition? Advice needed.

thanks
varieze is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-29-2011, 08:06 AM   #2
Dave Box
Respect the Cart
 
Dave Box's Avatar
E-Z-GO
 
Join Date: May 2010
Location: Rocky Mount, Virginia
Posts: 2,190
Default Re: engine runs irratic

Yes that is an issue. If the charging voltage goes to 18 volts the ignitor will overheat and malfunction. If this is the case then you should address the issue before you damage and expensive part. Place a voltmeter across the battery and go for a ride. Does the voltage stay at substantially 14 to 15 volts or does it hit 18 volts?

The most common problem is corroded ground wires so if you have an issue I would remove them and clean the lugs and studs, this free fix may be all you need.

Dave
Dave Box is offline   Reply With Quote
Old 09-29-2011, 08:25 AM   #3
varieze
Not Yet Wild
 
Join Date: Sep 2011
Posts: 3
Default Re: engine runs irratic

will clean the terminals and hook up a volt meter, thanks, will post results
varieze is offline   Reply With Quote
Old 09-29-2011, 02:38 PM   #4
varieze
Not Yet Wild
 
Join Date: Sep 2011
Posts: 3
Smile Re: engine runs irratic

cleaned everything and checked voltage still the same. It would jump from
14.? to 19+ .. Changed regulator and all is well. Was told that when the voltage jump occdured that it made the generator act like a 1 hp motor drawing power. Thanks for the help.
varieze is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Engine runs then stops--will not restart Gas Club Car
Engine stutters/runs erratic Gas Yamaha
2000 gas TXT Engine Runs in N. F/R only moves for a sec. Gas EZGO
Engine Runs But Won't Move Gas EZGO
engine runs backwards for a second Gas EZGO


All times are GMT -5. The time now is 08:32 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.