lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Columbia ParCar


Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-28-2018, 08:44 AM   #21
karly
Getting Wild
 
Join Date: Jun 2018
Posts: 83
Default Re: Columbia / ParCar comments/complaints

so what is the 800 #
karly is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-28-2018, 10:09 AM   #22
swb713
Gone Wild
 
swb713's Avatar
Columbia
 
Join Date: Aug 2018
Location: Orange County, California
Posts: 279
Cool Re: Columbia / ParCar comments/complaints

Quote:
Originally Posted by Tech Support View Post
That unit can have a 2 or a 4 factory deaigned lift kit but they are pricier than noat have to spend. (Check evtechnicalservices.com/parts and category accessories).

The one flash usually ends up being a controller needing replacement.
Thanks for the reply.
The factory designed lift kits are way more pricey than others and does not seem to increase the clearance, just lift the cart.

On the controller ... thanks for the reply on that one too. That's a bummer. those things are not cheap. I was hoping it would be a programming issue. I guess it is time to dig a little deeper and figure what route I want to take. But ... at least I didn't have to buy the cart too, just the horse to make it move.

Have a great day and thank you for being honest and helpful.
swb713 is offline   Reply With Quote
Old 07-18-2019, 05:43 PM   #23
skaggsd@me.com
Not Yet Wild
 
Join Date: Jul 2019
Posts: 3
Default Re: Columbia / ParCar comments/complaints

Good Day, I have a 1999 ParCar, 36 Volt. The cart came with a melted controller box Curtis 1204 J1,J2,J3 and the 4 main terminals. I updated with the newer curtis box that has a side J4 pin and a white 4 block connector which I didn't use either. I also replaced the microswitch in the potentiometer. As of now I turn the key on and push the pedal and the solenoid just clicks. It does the same in forward and reverse. I have went through the wiring schematics and everything appears to be connected as should. I read something about if it clicks in the solenoid it is on the high voltage side. Just trying to get a better idea of what is going on. I jumped wires on motor and did turn it over with out the cart wiring. Thanks for the help!
skaggsd@me.com is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Columbia ParCar


Thread Tools
Display Modes


Similar Threads
Thread Forum
New member with Columbia Parcar Columbia ParCar
92 Columbia ParCar Build Gas Columbia ParCar
86 Columbia ParCar Gas Columbia ParCar
Need Help Identifying a Columbia ParCar Gas Columbia ParCar
2002 48v Columbia Parcar Electric golf carts


All times are GMT -5. The time now is 04:19 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.