lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 03-07-2019, 05:43 AM   #1
peter.tygh
Not Yet Wild
E-Z-GO
 
Join Date: Mar 2019
Location: Top End of Australia
Posts: 41
Default EZGO RXV 2013 Brake Wiper Fault

Hi Everyone, very new to the site been trying to get wild all day with zero success, so I'm trying the question in the right forum I hope, I'm trying to get some info on a 1206AC-5211 controller with a brake wiper fault, it has being a intermittent fault that seem to clear after disconnecting power (battery isolation) but now seem to have failed completely, the brake won't release in tow as well, have looked online with no reference to this fault plus the Curtis manuals that I can find don't have anything on the 1206AC, I'm hoping someone can point me in a direction, I have input from the accelerator switch, plus a ramp % as well, on the 1313 reader, cheers pete from Oz
peter.tygh is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 03-07-2019, 07:04 AM   #2
usgicollector
Gone Wild
E-Z-GO
 
Join Date: Mar 2014
Location: NE Indiana & SW Florida
Posts: 2,814
Default Re: EZGO RXV 2013 Brake Wiper Fault

Have you checked the fuse by the controller cover?
usgicollector is offline   Reply With Quote
Old 03-07-2019, 08:01 AM   #3
peter.tygh
Not Yet Wild
E-Z-GO
 
Join Date: Mar 2019
Location: Top End of Australia
Posts: 41
Default Re: EZGO RXV 2013 Brake Wiper Fault

I will confirm tomorrow morning, but the fault was intermittent before this, I found a Curtis rep in Newcastle today saying the calibration on the accelerator may be out on a warn spring return??, plus a possible bad connection put parameters out, again I'll check, I just can't see any brake wiper fault on diagnostic charts for the 1206AC, is there some reference that I've missed, the witching hour is closing in & Friday is a hour & a bit away
peter.tygh is offline   Reply With Quote
Old 03-07-2019, 08:26 AM   #4
BobBoyce
Gone Insane
E-Z-GO
 
Join Date: Oct 2015
Location: TN/NC/GA Tri-state area
Posts: 3,952
Default Re: EZGO RXV 2013 Brake Wiper Fault

Quote:
Originally Posted by peter.tygh View Post
I will confirm tomorrow morning, but the fault was intermittent before this, I found a Curtis rep in Newcastle today saying the calibration on the accelerator may be out on a warn spring return??, plus a possible bad connection put parameters out, again I'll check, I just can't see any brake wiper fault on diagnostic charts for the 1206AC, is there some reference that I've missed, the witching hour is closing in & Friday is a hour & a bit away
Welcome to one of the issues seen with a damaged controller that had suffered a short between a 5V digital circuit and a 48V source. The internal 5 VDC regulator has become damaged. You can send it to FSIP (Flight Systems Industrial Products) for replacement, or buy a replacement. The member usgicollector here may still have one available.

Bob
BobBoyce is offline   Reply With Quote
Old 03-07-2019, 09:12 AM   #5
peter.tygh
Not Yet Wild
E-Z-GO
 
Join Date: Mar 2019
Location: Top End of Australia
Posts: 41
Default Re: EZGO RXV 2013 Brake Wiper Fault

Thanks Bob,
I will grab 6hrs snooze & check out the fuse,by the sounds I'll be chating with usgicollector real soon
peter.tygh is offline   Reply With Quote
Old 03-19-2019, 07:29 PM   #6
peter.tygh
Not Yet Wild
E-Z-GO
 
Join Date: Mar 2019
Location: Top End of Australia
Posts: 41
Default Re: EZGO RXV 2013 Brake Wiper Fault

Gooday everyone, thanks for the help, final got this cart on the hoist, started swapping bits of my RXV, turned out to be the brake wiper, it totally failed, gave weird faults, unplugged gave fault, plugged back in it disappeared, well its still going now, got a bit to learn on these later model RXV, know doubt I'll need your help again cheers pete
peter.tygh is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2013 RXV Curtis: Throttle wiper fault Electric EZGO
2013 EZGO Freedom RXV No BRAKE LIGHTS Electric EZGO
Carryall 232 Speed Sensor Fault/ Anti tamper Fault Electric Club Car
2013 club car Precedent vs 2013 EZGO RXV Electric Club Car


All times are GMT -5. The time now is 08:32 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.