lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-23-2009, 01:43 PM   #1
7sec.cuda
Not Yet Wild
 
Join Date: Jun 2009
Posts: 4
Default power issues

i am having power issues with my late 80s early 90s (not sure)gas cart i tow my 3000# racecar with it around the pits it was good up until this year now this year has a hard time pulling it no power at all even without the car its very sluggish the only way it has some power is if i try to bypass the governor its better under full throttle but not great i changed the fuel filter,rebuilt the carb,new belt ,checked the clutch did a compression check,leakdown,new plug removed exhaust(thought it was clogged) nothing seemed to make it better any suggestions? thanks in advance
7sec.cuda is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-23-2009, 01:52 PM   #2
spriddle
Admin
 
spriddle's Avatar
Yamaha
 
Join Date: Dec 2006
Location: TN
Posts: 101,453
Default Re: power issues

Check the engine mounts and make sure they are not wore out and allowing the engine to travel back to far and not put any tention on the belt. Also check the little tention cable under the air box to see if it is broken or in need of adjusting. Another thing to check is the little c-clip on the inner part next to the transmission/axle of the drive shaft on the rear clutch system. It may be missing and not allowing the clutch to keep the belt riding high.

spriddle is offline   Reply With Quote
Old 09-23-2009, 07:02 PM   #3
smallblock450sl
Sometime's............
 
smallblock450sl's Avatar
Yamaha
 
Join Date: Oct 2007
Location: Tacoma Washington
Posts: 11,759
Default Re: power issues

Are you running the original air box assy? If so just onhook the hose at the carb, fold it out of the way and test drive it. If it runs better amy have air box sealing problems.
smallblock450sl is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
Looking at a G1 issues? Gas Yamaha
Key issues Electric Club Car
94 EZ GO Marathon 36V / Power issues Electric EZGO
Power in Reverse/Little Power in Forward Gas Harley Davidson
For those having issues Announcements


All times are GMT -5. The time now is 10:39 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.