lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 10-19-2021, 04:33 PM   #1
2-old-carts
Not Yet Wild
 
Join Date: Jul 2020
Posts: 6
Unhappy Solid State Conversion blew the diode on the solenoid

I am started with a clean slate, no existing wiring, no motor, no solenoid, no accelerator/potentiometer...
Only thing from original cart is the key switch....

Used the CartsUnlimited Diagram from the BGW site.

Components:
Controller: Altrax SR48400
FnR Switch: Heavy duty EZGO
Accelerator: Curtis Type 0-k5 potentiometer/throttle pedal with 5 cables labeled POT High, POT Low, POT Wiper, Switch Output, Switch Common.
- I used POT High in J4, and POT wiper in J5. POT low was NOT used.
- SwOut went to FnR, SwCommon went to Solenoid + spade connector.

Solenoid: Curtis/Albright SW180-93 500Amp
--- documentation indicates :
- BOTH large top posts are positive (and connected by a capacitor)
- the top two spade connectors are positive
- the bottom two spade connectors are negative
- the right hand side of the spade connectors have a diode connecting the + and the -.
Wired in this manner, when I turned the key on everything seemed OK.
When I pushed the accelerator pedal the diode between the + and - spade connectors on the solenoid blew out violently.

I have double checked that I wired according to the diagram but obviously I have done something wrong.

Can anyone lend some expertise to help me figure this out?

Thank you.
Attached Images
File Type: jpg Current connections.jpg (151.0 KB, 0 views)
2-old-carts is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 10-19-2021, 05:11 PM   #2
Volt_Ampere
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 4,111
Default Re: Solid State Conversion blew the diode on the solenoid

You probably had the diode in backwards. The Banded end has to go to the Plus on the solenoid.
Volt_Ampere is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
36V Solid State Conversion Electric Club Car
99 CC DS solid state conversion HELP Electric Club Car
Solid state conversion Electric EZGO
G2 conversion to solid state Electric Yamaha
G2 f/r on a solid state conversion Electric Yamaha


All times are GMT -5. The time now is 04:13 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.