lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 04-11-2021, 05:10 PM   #1
Brandon h
Not Yet Wild
 
Join Date: Jul 2020
Posts: 34
Question 88 DS not running correctly

The cart is newer to me. It ran great for a day then it started bogging at higher throttle. I had a new carb just haven’t used it. Put it on and it still wouldn’t run correctly. Fuel pump is in good shape along with filters. Put the old carb back on after cleaning it and still the same thing. Tried a new spark plug also. There is fresh gas along with fuel filters. Any advice would be appreciated
Brandon h is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
bypass my OBC correctly Electric Club Car
Yamaha Golf Cart G1 not running correctly Gas Yamaha
90s Club Car not running correctly Gas Club Car
Is this wired correctly? Electric EZGO
G8-Is it running correctly? Gas Yamaha


All times are GMT -5. The time now is 03:02 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.