lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 04-01-2009, 04:04 AM   #1
LJM449
Not Yet Wild
 
Join Date: Mar 2009
Posts: 3
Default No Start-just Cranks-98 Ezgo Gas

Hi There-i Just Got This Cart And Can't Figure It Out. It Is A Robin Engine-they Were Riding It And It Jerked And Said It Back-fired And Quit. I Thought It Was A Fuel Pump But Shot It With Starting Fluid And Still Nothing. Took The Oil Cap Off And The Cam Is Turning. Checked Spark-has Spark But I'm Not Sure How Hot It Is-was In The Sun. Checked All Connectors And Seem Tight. Anything You Could Suggest Would Be Great. Thanks To All-great Site!!! Larry
LJM449 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 04-01-2009, 06:39 AM   #2
ruredy
Born Wild
 
ruredy's Avatar
 
Join Date: Mar 2007
Location: Clover SC.
Posts: 5,552
Default Re: No Start-just Cranks-98 Ezgo Gas

It needs 3 things to run
1 Fuel
2 compression
3 fire
You said it's getting fire or spark, and you also said it won't hit a lick with starting fluid. That kinda says to me that it's not sucking in the starting fluid into the cylinder. That would make me think it's a compression or valve problem. Take the plugs out and make sure the pistons are moving, if so, adjust the valves and try a compression test.
I am assuming your correct about the fire and fuel, if not it could be any number of problems.
ruredy is offline   Reply With Quote
Old 04-02-2009, 11:25 PM   #3
bhfear
EZ-GO-N
 
bhfear's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Geneseo, IL
Posts: 505
Default Re: No Start-just Cranks-98 Ezgo Gas

welcome to the forum
bhfear is offline   Reply With Quote
Old 04-07-2009, 06:59 AM   #4
divot61
Gone Wild
 
divot61's Avatar
E-Z-GO
 
Join Date: Apr 2009
Location: indiana
Posts: 274
Default Re: No Start-just Cranks-98 Ezgo Gas

yes, adjust the valves at .006, and make sure the spark is good and blue, if not replace the igniter
divot61 is offline   Reply With Quote
Reply

Tags
was running-quit!!!
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
cranks fine Gas EZGO
EZgo 2 stroker will not start Gas EZGO
EZGO will not start in neutral Gas EZGO
where to start on 95 ezgo Gas EZGO
94 EZGO start to finish Members Rides


All times are GMT -5. The time now is 05:27 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.