lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-18-2020, 10:38 AM   #11
Dabble Inn
Nincompoop Club Member
 
Dabble Inn's Avatar
E-Z-GO
 
Join Date: Jun 2016
Location: Idaho
Posts: 1,067
Default Re: Problems after 1989 3PG HEI upgrade, need help please!

Boy, that 4 second video was quick. Before I watched the second video I was going to say the fuel pump output looks ok........

But after seeing it run is does seem like it's starving, hmmmm?
Dabble Inn is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-18-2020, 10:59 AM   #12
Dabble Inn
Nincompoop Club Member
 
Dabble Inn's Avatar
E-Z-GO
 
Join Date: Jun 2016
Location: Idaho
Posts: 1,067
Default Re: Problems after 1989 3PG HEI upgrade, need help please!

Question; when you let off the throttle are you letting off far enough to kill the ignition momentarily? Just wondering if maybe it's resetting/restarting the module if you are, IF you're not then I gotta say fuel starvation..... Just thinking out loud lol

EDIT;
I also see a white puff of smoke at 15 seconds in, and it looks like you have the air filter disconnected at the carb. Could it be getting too much air and leaning itself out? I know I know, I'm reaching lol
Dabble Inn is offline   Reply With Quote
Old 08-18-2020, 08:05 PM   #13
rxguy1976
Not Yet Wild
 
Join Date: Aug 2020
Posts: 17
Default Re: Problems after 1989 3PG HEI upgrade, need help please!

Quote:
Originally Posted by Dabble Inn View Post
Question; when you let off the throttle are you letting off far enough to kill the ignition momentarily? Just wondering if maybe it's resetting/restarting the module if you are, IF you're not then I gotta say fuel starvation..... Just thinking out loud lol

EDIT;
I also see a white puff of smoke at 15 seconds in, and it looks like you have the air filter disconnected at the carb. Could it be getting too much air and leaning itself out? I know I know, I'm reaching lol
Thinking more about the feathering that I was doing with the throttle I would have to say...Yes, when letting off the throttle it is far enough to kill the ignition momentarily.

Otherwise it just dies like there is no spark. It's getting fuel, when lifting and then restarting it will load with fuel and backfire once in a while on restart.

It does the same thing with the air filter connected or disconnected. That old muffler has a few holes in it, that's where the puff came from. Lol.

Thanks for looking at the videos. Appreciate it.

I am open to any suggestions...
rxguy1976 is offline   Reply With Quote
Old 08-18-2020, 08:11 PM   #14
rxguy1976
Not Yet Wild
 
Join Date: Aug 2020
Posts: 17
Default Re: Problems after 1989 3PG HEI upgrade, need help please!

Wish I had good news. Swapped out the ignition module. No change. It's gotta be something electrical, the way it falls off....

Dang cart gremlins again.


Not sure what to try now. Go through all the wiring again. Gonna ponder it for a while. It'll be a couple of weeks before I can try something else. The cart is at our cabin in northern Michigan and we are going downstate for a couple weeks.

I did check the resistance on the pulser, which was good, but is there any other way to check/diagnose them more thoroughly?

Thanks again cart around and Dabble Inn.


I'll be around here a bit if either of your guys have a Eureka! moment.
rxguy1976 is offline   Reply With Quote
Old 08-19-2020, 04:30 PM   #15
cart around
Test before replacing
E-Z-GO
 
Join Date: Aug 2013
Location: Ohio side of the Pennsylvania border.
Posts: 3,293
Default Re: Problems after 1989 3PG HEI upgrade, need help please!

I asked a few days ago, but apparently never hit the post button.

What drove you to install the HEI mod? Was it doing something weird?
cart around is offline   Reply With Quote
Old 08-19-2020, 08:51 PM   #16
rxguy1976
Not Yet Wild
 
Join Date: Aug 2020
Posts: 17
Default Re: Problems after 1989 3PG HEI upgrade, need help please!

Quote:
Originally Posted by cart around View Post
I asked a few days ago, but apparently never hit the post button.

What drove you to install the HEI mod? Was it doing something weird?

Not sure how to describe it, one day it would run great, the next it would hesitate and act weird..kinda like it does now, but would stumble then go again without really falling flat like it does now...I checked the spark it was weak and intermittent. So I went with the HEI mod. Looking back...probably should have done a little more diagnostic stuff, but the HEI mod looked like the best route at the time. I figured it wouldn't hurt to do it anyways. Look what that got me.. LOL

Thanks
rxguy1976 is offline   Reply With Quote
Old 09-15-2020, 07:50 PM   #17
rxguy1976
Not Yet Wild
 
Join Date: Aug 2020
Posts: 17
Default Re: Problems after 1989 3PG HEI upgrade, need help please!

Update on the HEI.

Swapped out the BWD CBE4 ignition module for the Autozone DR100.

Eureka!!!!!!! It runs great.

Thanks every one for the help.
rxguy1976 is offline   Reply With Quote
Old 10-01-2022, 06:30 AM   #18
49ford
Gone Wild
E-Z-GO
 
Join Date: Nov 2011
Location: SW MO
Posts: 242
Default Re: Problems after 1989 3PG HEI upgrade, need help please!

I've just ran into the same problem and am heading to town to buy another module.
49ford is offline   Reply With Quote
Old 10-02-2022, 07:36 AM   #19
49ford
Gone Wild
E-Z-GO
 
Join Date: Nov 2011
Location: SW MO
Posts: 242
Default Re: Problems after 1989 3PG HEI upgrade, need help please!

I found a new stock ignition box in the shop. I pulled the HEI out , put stock in and it ran great.
So, lesson is don't buy cheap HEI on internet. I wasted 12 on HEI and 20 on a coil, plus time making an aluminum plate to mount it.
A new quality HEI might have worked, but I quit on it.
49ford is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Marathon Upgrade to TXT Gas EZGO
marathon upgrade Electric EZGO
93 Marathon upgrade Lifted Golf Carts
'87 marathon 48V upgrade Electric Club Car
93 Marathon upgrade Electric EZGO


All times are GMT -5. The time now is 12:28 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.