lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-11-2022, 12:23 PM   #31
radioman
Gone Wild
E-Z-GO
 
Join Date: Jan 2014
Location: South Georgia
Posts: 1,106
Default Re: EZGO works one day, and doesn't the next

Good job splicing. Don't replace solenoid yet. It is likely not the cause of cart not working. You can include it on the order list when you find problem.
radioman is online now   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-11-2022, 12:56 PM   #32
XCOP1152
Not Yet Wild
 
Join Date: Aug 2022
Posts: 36
Default Re: EZGO works one day, and doesn't the next

Quote:
Originally Posted by radioman View Post
Good job splicing. Don't replace solenoid yet. It is likely not the cause of cart not working. You can include it on the order list when you find problem.
Will do. Thanks again for the help.

Thanks to everyone for taking the time to read my posts and try to help me. Hopefully this thing will break down again today or tomorrow and I can do some more troubleshooting.
XCOP1152 is offline   Reply With Quote
Old 08-11-2022, 01:09 PM   #33
XCOP1152
Not Yet Wild
 
Join Date: Aug 2022
Posts: 36
Default Re: EZGO works one day, and doesn't the next

…. And I didn’t even have to wait long. The cart is not working again.

Voltage across pin one and two (black and white) when the key is on and go pedal is NOT pressed is ZERO. Voltage immediately changes to 14.4 volts when go pedal is pressed. It stays at 14.4 volts no matter how far I press the go pedal.
XCOP1152 is offline   Reply With Quote
Old 08-11-2022, 01:10 PM   #34
XCOP1152
Not Yet Wild
 
Join Date: Aug 2022
Posts: 36
Default Re: EZGO works one day, and doesn't the next

Quote:
Originally Posted by radioman View Post
That suggests the solenoid contacts may be welded together and you may not hear a click. Welded contacts may not keep this cart from working. Before you start the trouble shooting chart diagnosis routine suggest you make this measurement. While the cart is in working mode measure the voltage between pins 1 and 2 (black and white wires) on the six pin connector on top of the controller as you press the pedal. This is the signal coming from the Inductive throttle sensor (ITS) through the Molex connector and wiring that was originally suspect. You should measure around 2.5 volts no pedal and increase as pedal is pressed. When the cart is not working repeat this measurement. It is hard to troubleshoot for this intermittent problem when the cart is working.
My first cart was very similar to yours. I had the same symptoms as you are having. This is why I came for help here on BGY forums 8 years ago. My problem proved to be the Molex connector was corroded and the ITS proved intermitter. That old cart was a real work horse when it was working.
…. And I didn’t even have to wait long. The cart is not working again.

Voltage across pin one and two (black and white) when the key is on and go pedal is NOT pressed is ZERO. Voltage immediately changes to 14.4 volts when go pedal is pressed. It stays at 14.4 volts no matter how far I press the go pedal.
XCOP1152 is offline   Reply With Quote
Old 08-11-2022, 01:45 PM   #35
radioman
Gone Wild
E-Z-GO
 
Join Date: Jan 2014
Location: South Georgia
Posts: 1,106
Default Re: EZGO works one day, and doesn't the next

ITS. If the pedal box is still open use a hair drier or something cool to change the temperature of the ITS module and see if it goes back to working. Be careful because the solenoid contacts are welded and the cart is set to go if the ITS starts working.

Last edited by radioman; 08-11-2022 at 02:04 PM.. Reason: caution
radioman is online now   Reply With Quote
Old 08-11-2022, 02:16 PM   #36
MacGyverr
Not Yet Wild
 
Join Date: Nov 2020
Posts: 58
Default Re: EZGO works one day, and doesn't the next

if the solenoid is welded you would have voltage on both sides of it. just saying. i,m not a pro like the rest of you. I have had seen a bad its which is a possibilty .
MacGyverr is online now   Reply With Quote
Old 08-11-2022, 02:22 PM   #37
XCOP1152
Not Yet Wild
 
Join Date: Aug 2022
Posts: 36
Default Re: EZGO works one day, and doesn't the next

Quote:
Originally Posted by radioman View Post
ITS. If the pedal box is still open use a hair drier or something cool to change the temperature of the ITS module and see if it goes back to working. Be careful because the solenoid contacts are welded and the cart is set to go if the ITS starts working.
I am excited to try this, but I will probably have to wait until morning. Right after my last post I got called into work, and may be here for a while.

Thanks for the advice. I will test and post this ASAP.
XCOP1152 is offline   Reply With Quote
Old 08-12-2022, 12:10 PM   #38
XCOP1152
Not Yet Wild
 
Join Date: Aug 2022
Posts: 36
Default Re: EZGO works one day, and doesn't the next

Quote:
Originally Posted by XCOP1152 View Post
I am excited to try this, but I will probably have to wait until morning. Right after my last post I got called into work, and may be here for a while.

Thanks for the advice. I will test and post this ASAP.
As luck would have it the cart has been working all day today. I will be testing it throughout the day.
XCOP1152 is offline   Reply With Quote
Old 08-15-2022, 09:48 AM   #39
XCOP1152
Not Yet Wild
 
Join Date: Aug 2022
Posts: 36
Default Re: EZGO works one day, and doesn't the next

It has been a few days, and the cart is still running properly. Previously the weather has been unreasonably hot and humid, but it started getting cooler a few days ago. I do not know if that has anything to do with the cart running or not. As soon as it malfunctions again I will be back at it, and will update here.

Thanks again to everyone who has helped!
XCOP1152 is offline   Reply With Quote
Old 08-17-2022, 08:35 AM   #40
acguy_409
Not Yet Wild
 
Join Date: Jun 2021
Posts: 15
Default Re: EZGO works one day, and doesn't the next

Just my .02. All the dirt, mud, and water in the F-R switch can't be good. Good electrical troubleshooting includes visual inspection. Your fifth picture (far right) shows your solenoid, which has oxidized terminals(a possible symptom of failure), and I can't see the bottom cable, but it appears to maybe have been heated/melted insulation. Inspect the large posts for discoloration, which is an obvious indication of heat damage. A bad one might be dark in color, or even orange. Solenoids can undoubtedly fail but still click when activated if this is the failure mode. The clicking is the only magnetic slug moving, but it doesn't mean there is good electrical continuity and power transmission capability between the large contacts. Conversely, a solenoid that does not click, may not be getting excited by the coil, or may just plain be bad internally. Again, yours is oxidized on the coil terminals. I have replaced several that didn't click and were bad, and others that clicked, but were bad. I have also had solenoids welded, causing hard power to be applied to the controller constantly when the key was on. The 500 ohm resistor precharges the controller thru these same contacts, and will show voltage on both large terminals, and is not necessarily an indication of failure, so you have to isolate it from the power circuit to troubleshoot the solenoid properly. Either way, don't overlook the many failure mode possibilities of this 29 dollar part that in my opinion is a weak link in these carts.
acguy_409 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Ezgo Rxv works only in “tow” position Electric EZGO
Night of the Living Dead? Cart works, then doesn't, then does, then... Electric Club Car
Powerwise Charger works but doesn't fully charge batteries Electric EZGO
Sometimes it works and sometimes it doesn't???? Electric Club Car


All times are GMT -5. The time now is 02:56 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.