lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 04-07-2012, 01:36 PM   #1
superclubmaker
Not Yet Wild
E-Z-GO
 
Join Date: Apr 2012
Location: Epping, NH
Posts: 3
Default Battery smokes when charger is pluged in, Confused.

Ok, I am another newbie here with an issue, After reading many different wiring diagrams and many of the problems others have posted here, I thought I would post my situation.

I have a 1989 EZ go that had a 3 wire resistor system that I just switched out to a modern resistor that is one thick slinky. LOL, I just nailed my wealth of knowledge in terminology.

All connections to the resistor coil bolted up as they were before I took out the old one, I made sure that the coil stayed straight and all looks good there. The only thing different is I only had a #6 cable instead of a #4 going from the resistor to the motor. The old resistor used to get so hot it would melt the wires and I would be using a garden hose to cool it down.

Sometimes when I take the key out and step on the pedal it will move, is one issue. My main issue is that Battery #6 I believe got really hot when I plugged in the charger and smoke came out of it. I unplugged it after a minute, checked the fluid and it had started to boil. I added water and let the thing cool down. The next day I tried putting the charger on and it began to smoke again. So I disconnected the battery and got a reading of 5.96 volts on every battery. So I guess I am somewhat confused.

Also, the person that originally worked on it seems to have an extra Negative from battery #6 going to the frame. It was like that for years but after reading it seems that this wire shouldn't exist. When I remove that wire and test with the volt meeter I still have voltage to the frame.

So I guess I would like some advice, I am thinking of changing the one battery with another 6v just to see if I can attach the charger without blowing the cart up. Any thoughts? Solenoid? Micro switch? Dead battery? HELP.
superclubmaker is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 04-07-2012, 04:25 PM   #2
scottyb
Happy Carting
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 72,156
Default Re: Battery smokes when charger is pluged in, Confused.

Once in a while I read a thread like this that will make all of my warning lights come on & buzzers go off!

Can you stop & take lots of pics and attach them to this thread so we can grasp what it is you are asking us about.
scottyb is offline   Reply With Quote
Old 04-07-2012, 04:38 PM   #3
superclubmaker
Not Yet Wild
E-Z-GO
 
Join Date: Apr 2012
Location: Epping, NH
Posts: 3
Default Re: Battery smokes when charger is pluged in, Confused.

Sorry to upset you, I will take some pictures. I think I have multiple things going on. Thank you
superclubmaker is offline   Reply With Quote
Old 04-07-2012, 04:44 PM   #4
superclubmaker
Not Yet Wild
E-Z-GO
 
Join Date: Apr 2012
Location: Epping, NH
Posts: 3
Default Re: Battery smokes when charger is pluged in, Confused.

I guess if I question would be if I upgraded the resistor coil, would I have to upgrade the solenoid? I'll get some pictures.
superclubmaker is offline   Reply With Quote
Old 04-07-2012, 05:05 PM   #5
gornoman
Stay thirsty my friends!
 
gornoman's Avatar
Mixed Breed
 
Join Date: Jan 2007
Location: Suburban Chicago
Posts: 24,189
Default Re: Battery smokes when charger is pluged in, Confused.

Quote:
Originally Posted by scottyb View Post
Once in a while I read a thread like this that will make all of my warning lights come on & buzzers go off!

Yeppers, this one's gonna be a long road...... Hang in there, superclubmaker, these guys will get you sorted.
gornoman is offline   Reply With Quote
Old 04-08-2012, 04:40 AM   #6
yurtle
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 8,988
Default Re: Battery smokes when charger is pluged in, Confused.

Quote:
Originally Posted by gornoman View Post
Yeppers, this one's gonna be a long road...... Hang in there, superclubmaker, these guys will get you sorted.
Is this the kind of instance your avatar was chosen for?
yurtle is offline   Reply With Quote
Reply

Tags
ez go 1989
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
still confused Gas Yamaha
confused Gas Yamaha
confused help!!!! Electric Yamaha
Confused?????? Electric EZGO


All times are GMT -5. The time now is 12:12 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.