lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-25-2012, 07:31 PM   #1
dwcampb
Not Yet Wild
 
Join Date: May 2011
Posts: 2
Default Powerwise Charger works but doesn't fully charge batteries

I have 36v powerwise charger II. I have replaced the batteries in the last 6 months which are Trojan T105's. I have an digital volt meter that is attached to the pack and displays the volts all the time. After the charger turns off the volt reading will drop to 37.8 or 37.6 almost immediately. I never see the volts go up over 40 as was suggest should happen. The ammeter is not working on the charger. What I am trying to figure out is what is the most likely cause for the charger not charging the pack fully? Would the ammeter not working cause this issue? Do you think the control board is going bad or is the another likely culprit? I have cleaned all the battery terminals even though they are new. I have ordered new cables but they are still on their way. Any suggestions would be great. Thanks!!
dwcampb is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-26-2012, 07:41 AM   #2
JohnnieB
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 19,654
Default Re: Powerwise Charger works but doesn't fully charge batteries

Welcome to BGW!

If the ammeter is not showing any current flow and the battery pack voltage is not climbing into the 44-46V range before the charger shuts off, either the charger is not working, the battery pack is bad, or the charger is not connected to the battery pack correctly.


Since total charging current flows through the ammeter and you do not see the needle deflecting upscale, either the fuses in the little round window are blown, the ammeter is blown or the diodes are blown.

Here's the service and owner's manuals I use for my PW II. They're for a Lesteronic II which is basically a Powerwise II with a different label.

Lots of good info in them.
JohnnieB is offline   Reply With Quote
Old 06-26-2012, 09:07 AM   #3
dwcampb
Not Yet Wild
 
Join Date: May 2011
Posts: 2
Default Re: Powerwise Charger works but doesn't fully charge batteries

Thanks for the response, I will check out these testing procedures in the manual and see what I can find.
dwcampb is offline   Reply With Quote
Reply

Tags
batteries, charger
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
new batts and charger wont charge, charger works on other carts Electric Club Car
EZGO Textron "Total Charge 111" won't auto shut off when batteries are fully charged Electric EZGO
Charger wont charge fully Electric Club Car
PowerWise Charger wont charge Electric Club Car
Charger wont fully charge... Electric EZGO


All times are GMT -5. The time now is 10:11 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.