lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-29-2021, 02:06 PM   #1
Joeray
Not Yet Wild
 
Join Date: Apr 2021
Posts: 11
Default 2 stroke ezgo sluggish at starting off

Have a 1991 ezgo 2 stroke that is real slow to start off when you press the accelerator pedal. Hold it down and eventually it speeds up and starts to move. Once you get it going you can stop and accelerate again and it takes right off. Usually only doe s this when you first start off. Replaced drive clutch and carburetor. Just real slow to get everything moving.
Joeray is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-07-2022, 07:55 AM   #2
49ford
Gone Wild
E-Z-GO
 
Join Date: Nov 2011
Location: SW MO
Posts: 242
Default Re: 2 stroke ezgo sluggish at starting off

old post, but did you figure out the problem?
49ford is offline   Reply With Quote
Old 08-07-2022, 08:36 AM   #3
cart around
Test before replacing
E-Z-GO
 
Join Date: Aug 2013
Location: Ohio side of the Pennsylvania border.
Posts: 3,284
Default Re: 2 stroke ezgo sluggish at starting off

He didn't give a good description of the problem. That's why he never got a reply.

I would suggest describing exactly what your cart is doing with as much detail as possible.

We will then try to help you instead of trying to troubleshoot your cart through his description.
cart around is offline   Reply With Quote
Old 08-07-2022, 10:11 AM   #4
49ford
Gone Wild
E-Z-GO
 
Join Date: Nov 2011
Location: SW MO
Posts: 242
Default Re: 2 stroke ezgo sluggish at starting off

I have an 83 ezgo with the 2pg. I initially changed the drive clutch because it seemed loose and I thought rattled.
Now I've got the engine to run fairly good, not great, it seems like its running governed, but the governer is removed.
The Problem I'm trying to solve is that the engine won't take off for several seconds after you throttle it. I have another 2pg that hits and runs right away so I don't think its normal. In reverse it starts twice as fast.In forward, it takes long enough it makes you wonder if its going to go at all.
Heres what I've done, checked, replaced.

New starter generator. No help, no change, now I have a spare. Though I had to change the old large diameter pulley to the new starter to match the vbelt length.

New ignition module, checked firing with timing light, blue fire at plug. New plug at .028. I have used 4, 5 and 6 heat range plugs gapped to .029, no change
Fuel tank, lines, cleaned. New 128to1 fuel. Fuel pump working, new filters in right direction. Carb cleaned extremely well including center meter. Float set at .200
New air filter, on or off no change.
Compression 110.
I separated the exhaust pipe to relieve pressure, and it wouldn't start any better.
49ford is offline   Reply With Quote
Old 08-07-2022, 11:16 AM   #5
Leon willis
Gone Wild
 
Leon willis's Avatar
E-Z-GO
 
Join Date: Mar 2022
Location: Ohio
Posts: 253
Default Re: 2 stroke ezgo sluggish at starting off

That sounds like the jug is worn out
Leon willis is offline   Reply With Quote
Old 08-07-2022, 12:02 PM   #6
cart around
Test before replacing
E-Z-GO
 
Join Date: Aug 2013
Location: Ohio side of the Pennsylvania border.
Posts: 3,284
Default Re: 2 stroke ezgo sluggish at starting off

110 compression is good, so NO the jug isn't worn out.

Running better in reverse is a sign of worn crankshaft seals.

I need a better description of what happens when you press the pedal, but before it starts.

Does it spin fast on the starter, or does the starter hesitate and then start turning?

A you tube video would great.
cart around is offline   Reply With Quote
Old 08-07-2022, 12:12 PM   #7
49ford
Gone Wild
E-Z-GO
 
Join Date: Nov 2011
Location: SW MO
Posts: 242
Default Re: 2 stroke ezgo sluggish at starting off

I'll try to do a video.Haven't done one yet. It would be easier to see and hear it. I rechecked the compression, its 120.
49ford is offline   Reply With Quote
Old 08-07-2022, 02:07 PM   #8
49ford
Gone Wild
E-Z-GO
 
Join Date: Nov 2011
Location: SW MO
Posts: 242
Default Re: 2 stroke ezgo sluggish at starting off

Ok, first try at a youtube,

https://youtube.com/shorts/qEppx3xlXW8
49ford is offline   Reply With Quote
Old 08-07-2022, 02:24 PM   #9
CP241
Nincompoop village idiot
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: Michigan
Posts: 8,306
Default Re: 2 stroke ezgo sluggish at starting off

Quote:
Originally Posted by cart around View Post
110 compression is good, so NO the jug isn't worn out.

I wouldnt expect any less of a response from him

Quote:
Originally Posted by cart around View Post

Running better in reverse is a sign of worn crankshaft seals.
.

If I were a betting man Id go with crank seals as well. Its spinning and clearly has compression. Sounds okay once it starts but Id be replacing crank seals before trying to dive any further into it.
CP241 is online now   Reply With Quote
Old 08-07-2022, 03:23 PM   #10
cart around
Test before replacing
E-Z-GO
 
Join Date: Aug 2013
Location: Ohio side of the Pennsylvania border.
Posts: 3,284
Default Re: 2 stroke ezgo sluggish at starting off

Boy, that is a lot of cranking before getting fuel to fire. I really hate to tell somebody to rip it apart for seals on a guess, but I just don't know where else to go with that.

You already separated the exhaust pipe, but it could be clogged closer to the cylinder.

I also hear some weird clunking or banging that I can't identify.

The only other thing I would do before the crankshaft seals is pull the fuel pump apart and looked for a lower ripped diaphragm. I know that you said it's pumping good, but does it happen to foul out the plug any?
cart around is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
95 Medalist sluggish starting Gas EZGO
2 stroke gas ezgo 1990 sluggish no power Gas EZGO
1999 EZGO 4 stroke hard starting Gas EZGO
1981 EZGO Gas 2 Stroke starting issues after a hard run Gas EZGO
Hard Starting 1989 2 stroke EZGO Gas EZGO


All times are GMT -5. The time now is 01:22 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.