lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-11-2008, 04:28 PM   #1
jwalker1970
Not Yet Wild
 
Join Date: May 2008
Posts: 2
Default 2000 EzGo TXT 295 - No Power

I have a 2000 EZ go 295 that I gradually lost power over the last 2 months.

I have 135lbs compression on both cylinders.

I have switched carburators with a 1999 model 295. No change.

I have switched secondary clutch. No change.

Starts excellent.

Doesn't smoke.

It will go forward on the flat, but comes to a stop when going up a hill.

Runs out of power, but continues to run.

Please help.
jwalker1970 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-11-2008, 06:14 PM   #2
todwil
TOD WILD
 
todwil's Avatar
 
Join Date: Nov 2007
Location: YUMA AZ
Posts: 666
Default Re: 2000 EzGo TXT 295 - No Power

Do you still have the govenor at factory settings??
todwil is offline   Reply With Quote
Old 08-11-2008, 07:07 PM   #3
caddymankc
WILD
 
caddymankc's Avatar
E-Z-GO
 
Join Date: May 2007
Location: lebanon county,pa
Posts: 1,266
Default Re: 2000 EzGo TXT 295 - No Power

Adjust the valves to make sure its good, is the belt new? So the engine bogs down to nothing up hill or does it just stop moving with the engine still revving?
caddymankc is offline   Reply With Quote
Old 08-12-2008, 08:23 AM   #4
jwalker1970
Not Yet Wild
 
Join Date: May 2008
Posts: 2
Default Re: 2000 EzGo TXT 295 - No Power

Valves are set at .004 as per recommended.

Engine bogs down.

I have tightened the govenor spring- minimal gain, still not enough power to climb a small hill.

air filter is new.
jwalker1970 is offline   Reply With Quote
Old 08-12-2008, 09:02 AM   #5
ruredy
Born Wild
 
ruredy's Avatar
 
Join Date: Mar 2007
Location: Clover SC.
Posts: 5,552
Default Re: 2000 EzGo TXT 295 - No Power

Did you do both wet and dry compression test and leave one plug in while testing?
Does it backfire, hiccup, or miss?
How did the plugs look?
Is it a new belt or do you keep using the same one?
Are you running a shorter belt or have you tried one?
ruredy is offline   Reply With Quote
Old 08-12-2008, 07:07 PM   #6
cartworldinc
Not Yet Wild
 
cartworldinc's Avatar
 
Join Date: Aug 2008
Posts: 67
Default Re: 2000 EzGo TXT 295 - No Power

I'm gonna take a stab at it... LOL Your compression sounds unusually high, especially for a 8 year old cart. A cart that is acting this way would usually mean valves out of adjustment, but that usually means a slow or hard start. Your cart starts good and seems to run well at low rpm only. If you put it in neutral, can you get RPM's then? With all of these symptoms I would start looking for a restriction in the exaust system. This would prevent your engine from obtaining rpm's and would also cause no power. If your engine revs fine in neutral.... That blows my theory....LOL
cartworldinc is offline   Reply With Quote
Old 08-12-2008, 09:10 PM   #7
caddymankc
WILD
 
caddymankc's Avatar
E-Z-GO
 
Join Date: May 2007
Location: lebanon county,pa
Posts: 1,266
Default Re: 2000 EzGo TXT 295 - No Power

That is not a high reading for a newer cart like that.Its in the ok zone if it was done right.
caddymankc is offline   Reply With Quote
Old 08-13-2008, 09:51 AM   #8
WSBAT
Not Yet Wild
 
Join Date: Jul 2008
Posts: 3
Default Re: 2000 EzGo TXT 295 - No Power

I have a 1998 295cc and mine does the same thing no power on hills. I just rebuild the motor and put a 28 degree clutch on it and a 1" shorter belt and it didn`t seem to make much of a change. When I take off it seem like the clutch ingauges at a high RPM it really jerks you. It revs up good in netural.I can run it on the flat and it run great but when you hit a hill slows right down.

I have a lift kit and 22" tires?
WSBAT is offline   Reply With Quote
Old 08-13-2008, 10:08 AM   #9
rusty
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,236
Default Re: 2000 EzGo TXT 295 - No Power

Welcome to the forum jwalker1970...............
rusty is offline   Reply With Quote
Old 09-04-2008, 09:32 PM   #10
GXTsandman
Getting Wild
 
GXTsandman's Avatar
E-Z-GO
 
Join Date: May 2008
Location: SouthWest US
Posts: 122
Default Re: 2000 EzGo TXT 295 - No Power

Hows the drive clutch look?
GXTsandman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
86 ezgo power troubles Gas EZGO
2000 Ezgo Electric With Problems Electric EZGO
EZGO 2000 875 industrial Gas Gas EZGO
2000 Ezgo W/PDS Members Rides
Need Help With 99/2000 elct ezgo dcs Electric EZGO


All times are GMT -5. The time now is 11:28 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.