lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-26-2021, 08:45 PM   #1
SLAKfarmDad
Not Yet Wild
 
Join Date: Sep 2021
Posts: 3
Default TXT 48V still runs with Solenoid disconnected???

New member, i have used these forums as reference for most of my previous problems, but i have not found this problem in other threads. Thanks for the members for putting so much info out there.

I thought my solenoid was going bad and have been troubleshooting, confirming that the reed switch is ok, charge port is ok, key is ok. Had the cart on jack stands. i took the battery (+) and controller side bid cables off the solenoid, left the small cables in place. the solenoid clicked when i pressed the pedal, but i was surprised when the wheels started turning. Any thoughts on what is happening?

2014 TXT with stock curtis controller. Pack voltage at 50.8V

I started troubleshooting because we are intermittently losing power. i started with the throttle plunger, but it tested good. i am starting to think that my controller is faulty, but am hoping to get some advice on how ot confirm that before i have to drop $500 on a new control. if i do upgrade i am leaning towards a navitas or alltrax control. i like the navitas in theory because i have a large hill to my barn and want the ability to adjust braking and speed when my kids use the cart.

Last edited by SLAKfarmDad; 09-26-2021 at 08:46 PM.. Reason: punctuation
SLAKfarmDad is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-27-2021, 09:19 AM   #2
bronsonj
Gone Wild
 
bronsonj's Avatar
E-Z-GO
 
Join Date: Jan 2013
Location: Saint Petersburg, FL
Posts: 1,941
Default Re: TXT 48V still runs with Solenoid disconnected???

Did the wheels stop? The big capacitors in your controller will hold power for a little bit. Also there is a resistor that crosses the solenoid to keep those capacitors charged. If your wheels are up in the air there is very little drag and the current passing through the resistor might be enough to make the wheels turn slowly.

That or you have another connection to the battery pack that is not normal. I don't think that is likely, but one never knows. But honestly it sounds like the capacitor/resistor is allowing the wheels to move and isn't an issue.
bronsonj is offline   Reply With Quote
Old 09-27-2021, 02:03 PM   #3
SLAKfarmDad
Not Yet Wild
 
Join Date: Sep 2021
Posts: 3
Default Re: TXT 48V still runs with Solenoid disconnected???

Quote:
Originally Posted by bronsonj View Post
Did the wheels stop? The big capacitors in your controller will hold power for a little bit. Also there is a resistor that crosses the solenoid to keep those capacitors charged. If your wheels are up in the air there is very little drag and the current passing through the resistor might be enough to make the wheels turn slowly.

That or you have another connection to the battery pack that is not normal. I don't think that is likely, but one never knows. But honestly it sounds like the capacitor/resistor is allowing the wheels to move and isn't an issue.
I had the resistor off, but i did not think about the capacitors in the controller, i didn't really run the wheels for long, so it probably would not be enough to discharge them. i might try that tonight.

So now, i need to figure out what to try next.
SLAKfarmDad is offline   Reply With Quote
Old 09-27-2021, 02:44 PM   #4
JohnnieB
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 19,646
Default Re: TXT 48V still runs with Solenoid disconnected???

Need to take some voltage measurements when cart isn't working right to find and prove what the problem is.
Attached Images
File Type: jpg 48v TXT diagram.JPG (95.5 KB, 0 views)
File Type: jpg 48TXT -wiring diagram .jpg (149.5 KB, 0 views)
Attached Files
File Type: pdf 48V TXT Service Manual.pdf (4.28 MB, 0 views)
JohnnieB is offline   Reply With Quote
Old 09-27-2021, 04:02 PM   #5
SLAKfarmDad
Not Yet Wild
 
Join Date: Sep 2021
Posts: 3
Default Re: TXT 48V still runs with Solenoid disconnected???

Quote:
Originally Posted by JohnnieB View Post
Need to take some voltage measurements when cart isn't working right to find and prove what the problem is.
I have my multimeter in the cart with me all of the time now, any advice on where to start. sometimes it only happens for a few minutes, so i want to start in the most logical spot
SLAKfarmDad is offline   Reply With Quote
Old 09-27-2021, 05:09 PM   #6
JohnnieB
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 19,646
Default Re: TXT 48V still runs with Solenoid disconnected???

It sounds like the solenoid clicks when cart is misbehaving. That means the problem is in the high amp circuit. (Motor, solenoid contacts, thick cables, and controller, plus the ITS throttle.)

Connect voltmeter between the controller's B- terminal (Black test lead) and M- terminal (Red test lead).

Push pedal just far enough to make solenoid click and you should read full battery pack voltage (50.8V was mentioned). IF you get it, then slowly push pedal to floor and the voltage ought to decrease to 0V.

If it doesn't either controller or throttle is bad.

I'm not sure which pin the throttle signal is on, but it is either pin-1 (white wire) or pin-2 (black wire). When pedal is pushed just far enough to make solenoid click, you should get 1.0V +/-0.3V and when pedal is on floor it ought to be 2.7V +/-0.5V.

If the throttle checks out, the controller is bad. Replace it with an Alltrax XCT48400-TXT48 or larger.
JohnnieB is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Ezgo Txt Runs until you let off gas and solenoid clicks then only runs at 5mph Electric EZGO
04 precedent 48v runs then solenoid drops out Electric Club Car
2008 Club Car Precedent Runs with disconnected solenoid Electric Club Car
Cart only runs with Voltage Regulator green wire disconnected Gas EZGO
jumped solenoid runs fine Electric EZGO


All times are GMT -5. The time now is 01:58 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.