lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-09-2020, 04:06 PM   #1
chazman05
Not Yet Wild
Club Car
 
Join Date: Mar 2017
Location: New Braunfels, TX
Posts: 7
Default 2015 CLUB CAR VILLAGER 6 not working need help

My goft cart has gone dead. I charged it and checked all batteries 48v.

The solenoid wasnt clicking so I purchased another one Albright 48V. Hooked it up and its still dead in the water. The new solenoid had a jumper on the main terminals, my other did not but the rep said to leave it.

Any ideas, im not too knowledgeable with electric golf carts. Appreciate any help, as all Golf Cart repair folks are weeks out before being able to look at it.
chazman05 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-09-2020, 06:40 PM   #2
Fairtax4me
Off the deep end
 
Fairtax4me's Avatar
Club Car
 
Join Date: Dec 2015
Location: Charlottesburg Va
Posts: 5,390
Default Re: 2015 CLUB CAR VILLAGER 6 not working need help

48V is kind low for pack voltage. Does this cart have 6 8V batteries or 8 6v batteries?
You really should have about 50.9V total pack voltage for a fully charged pack.

Does the reverse buzzer work if you put it in reverse?
Do any of the battery cables have corrosion on the ends? all of them are clean and tight?
Did this problem arise out of nowhere? Was it driving and quit? Was it charging at home and worked one day and the next day it doesn't work?
Is the Tow/Run switch in Run?
If the solenoid is not clicking we first need to make sure it's getting pack voltage on the small terminals. With Tow Run switch in RUN, and Key ON you should have pack voltage on both small terminals.
Check for any fuses near the solenoid or controller and make sure they're not blown.
Fairtax4me is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2015 TXT Not Working after Reducer install Electric EZGO
2015 club villager 6 need more speed Electric Club Car
Villager Club Car won't go Gas Club Car
Club Car Villager Electric Club Car
'05 club car villager won't run Electric Club Car


All times are GMT -5. The time now is 08:49 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.