lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-30-2020, 03:11 PM   #1
namyot11
Getting Wild
Mixed Breed
 
Join Date: Jul 2011
Location: Wellington, Ohio
Posts: 96
Default DS Runs Slow, No Full Throttle

I have a 2011 DS IQ cart that runs at a very slow speed. Batteries are 1-year-old showing 50.3 volts at rest. When you press the accelerator pedal the monitor shows no foot input until the pedal is pressed more than halfway to the floor. When the pedal is pressed fully to the floor the throttle input tops out at 66%. I have looked through many of the threads with similar throttle problems but am still unsure as to what to do next.
namyot11 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-30-2020, 03:42 PM   #2
R&TBabich
Gone Wild
Club Car
 
Join Date: Apr 2020
Location: 1000 Oaks, SOCAL
Posts: 342
Default Re: DS Runs Slow, No Full Throttle

Quote:
Originally Posted by namyot11 View Post
I have a 2011 DS IQ cart that runs at a very slow speed. .... throttle input tops out at 66%. ... am still unsure as to what to do next.
Seems like a test of the MCOR throttle module is next.
If your MCOR is bad and you have an MCOR1 you might need a conversion kit to upgrade to an MCOR4.
https://evdrives.com/faq-documents/c...els-explained/
R&TBabich is offline   Reply With Quote
Old 08-30-2020, 03:50 PM   #3
namyot11
Getting Wild
Mixed Breed
 
Join Date: Jul 2011
Location: Wellington, Ohio
Posts: 96
Default Re: DS Runs Slow, No Full Throttle

The cart has an MCOR4 installed. It shows a steady climb from 0 to 66%no erratic or jumping around of the numbers.
namyot11 is offline   Reply With Quote
Old 08-30-2020, 03:56 PM   #4
R&TBabich
Gone Wild
Club Car
 
Join Date: Apr 2020
Location: 1000 Oaks, SOCAL
Posts: 342
Default Re: DS Runs Slow, No Full Throttle

Quote:
Originally Posted by namyot11 View Post
The cart has an MCOR4 installed. ....
Is it a made in China MCOR4 or an ITW Switches made in Mexico unit?
Attached Images
File Type: jpg MCOR4 Mexico.jpg (136.5 KB, 0 views)
R&TBabich is offline   Reply With Quote
Old 08-30-2020, 05:09 PM   #5
namyot11
Getting Wild
Mixed Breed
 
Join Date: Jul 2011
Location: Wellington, Ohio
Posts: 96
Default Re: DS Runs Slow, No Full Throttle

Pretty sure it said China on it, but I may be confused because every part I look at seems to say "made in China", lol.
namyot11 is offline   Reply With Quote
Old 08-30-2020, 05:11 PM   #6
namyot11
Getting Wild
Mixed Breed
 
Join Date: Jul 2011
Location: Wellington, Ohio
Posts: 96
Default Re: DS Runs Slow, No Full Throttle

Yep, went out to look at it, it is made in China.
namyot11 is offline   Reply With Quote
Old 08-30-2020, 05:21 PM   #7
movin-on
Gone Wild
Club Car
 
Join Date: Sep 2016
Location: Titusville, FL...Space Coast
Posts: 380
Default Re: DS Runs Slow, No Full Throttle

Your throttle linkage is probably worn...Look down from the top of the cart thru the floor where the go pedal contacts the linkage that goes to the mcor.....You can put a wire tie around the linkage to take up the slack...You'll figure it out when you look at it....It works..
movin-on is offline   Reply With Quote
Old 08-30-2020, 05:46 PM   #8
namyot11
Getting Wild
Mixed Breed
 
Join Date: Jul 2011
Location: Wellington, Ohio
Posts: 96
Default Re: DS Runs Slow, No Full Throttle

Already checked the linkage, it is tight, can't even fit a zip tie in there.
namyot11 is offline   Reply With Quote
Old 08-30-2020, 07:28 PM   #9
movin-on
Gone Wild
Club Car
 
Join Date: Sep 2016
Location: Titusville, FL...Space Coast
Posts: 380
Default Re: DS Runs Slow, No Full Throttle

How about the rod bracket and bushings...If your having trouble with throttle range it still sounds like a linkage problem since there aren't any adjustments..

https://www.amazon.com/10L0L-Club-10.../dp/B00WFQ2INY

or the oem one

https://www.amazon.com/Accelerator-B.../dp/B073VZDZG4
movin-on is offline   Reply With Quote
Old 08-30-2020, 09:03 PM   #10
namyot11
Getting Wild
Mixed Breed
 
Join Date: Jul 2011
Location: Wellington, Ohio
Posts: 96
Default Re: DS Runs Slow, No Full Throttle

Everything seems tight to me but I'll check it out again tomorrow. I'm leaning toward it have a bad MCOR. I'd hate to start throwing parts at it without a proper diagnosis.
namyot11 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Yamaha G1 Only Runs with full choke and full Throttle Gas Yamaha
G16 only runs full throttle with choke pulled Gas Yamaha
runs full throttle only Gas EZGO
Yamaha g16 only runs full throttle Gas Yamaha
G1 Only runs at full throttle Gas Yamaha


All times are GMT -5. The time now is 10:04 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.