lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-12-2020, 07:02 PM   #1
Knight Rider
Not Yet Wild
 
Join Date: Nov 2016
Location: Central Florida
Posts: 16
Default Driver Side Tail Light and Horn Not Working

I recently purchased a used custom club car via private sale. The cart is a 2014 precedent that was completely redone in October 2018. The prior owner put a mad Jax led light kit on it. It is a six seater and all accessories run off a dedicated 12 volt deep cell battery under the front seats.

When we purchased the cart the horn was not working but I didnít think much of it and the seller bought a replacement horn and had it shipped to our house. After we got the cart home we noticed that the driver side rear tail light does not work. Not when the lights are turned on or when the blinkers are turned on or flashers. Today I got around to replacing the horn and when I hooked it up and tried to use it, it makes a very Brief and quiet attempt to work but it does not.

I tried troubling shooting with the following:

I checked the fuse by the battery and it is in tact. I pulled out the light assembly and all 3 wires are hooked up (as well as the passenger side). The voltage reducer connection located in the front of the cart was in tact. I pulled apart the turn signal assembly at the steering wheel thinking there might be a pinched wire there but everything looks clean.

I live in a town where we need to make the cart street legal and register it. I need these issues fixed so I can get it on the road. Any thoughts amor suggestions are appreciated....
Knight Rider is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-12-2020, 10:54 PM   #2
buckmanmike
Gone Wild
 
buckmanmike's Avatar
 
Join Date: Oct 2007
Location: Snellville, Ga.
Posts: 1,187
Default Re: Driver Side Tail Light and Horn Not Working

Follow the wire from the light to reducer. Maybe pinched there. I dont think horn and light are related since other lights are working.
buckmanmike is offline   Reply With Quote
Old 09-12-2020, 11:03 PM   #3
Mooncarter
Gone Insane
 
Mooncarter's Avatar
Club Car
 
Join Date: Oct 2016
Location: Richmond, VA
Posts: 13,157
Default Re: Driver Side Tail Light and Horn Not Working

Test for 12 at the problem. If you are getting voltage there the bulb(s) are bad. If no voltage trace to see why not. I suspect it is somewhere between the good and non working tail lights. As buckman said, the horn is probably a separate issue. Is the relay for it clicking?
Mooncarter is offline   Reply With Quote
Old 09-12-2020, 11:06 PM   #4
Mooncarter
Gone Insane
 
Mooncarter's Avatar
Club Car
 
Join Date: Oct 2016
Location: Richmond, VA
Posts: 13,157
Default Re: Driver Side Tail Light and Horn Not Working

Quote:
Originally Posted by buckmanmike View Post
Follow the wire from the light to reducer. Maybe pinched there. I dont think horn and light are related since other lights are working.
He does not have a reducer.
Mooncarter is offline   Reply With Quote
Old 09-13-2020, 10:40 AM   #5
Knight Rider
Not Yet Wild
 
Join Date: Nov 2016
Location: Central Florida
Posts: 16
Default Re: Driver Side Tail Light and Horn Not Working

Not sure why I didnít think of this before I posted but I decided to swap tail lights and noticed the good one works on the bad side. Also noticed on the bad light that I started getting a very dim light and a reaction when I put the blinker on. Unless someone can think of another reason this might be caused, I am guessing it must be a bad light in which case now I have to try to find a matching one for sale.

As far as the horn, I hear a small tap sound when I press the button each time, but no horn sound. The old horn did not give any tap sound. The horn I am installing is pretty basic looking. I read on the forum to adjust a screw for sound but I donít see a screw on this horn. Any ideas? Thanks for the feedback.
Knight Rider is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Passenger side sits lower than driver side Electric Club Car
2004 CC Precedent, 1 tail light not working? Electric Club Car
WTB G8 driver side control arm Golf Carts and Parts
Passanger side Brake grabbing more than Driver side Electric Club Car
Wanted Front driver side light kit for EZGO 2002 Golf Carts and Parts


All times are GMT -5. The time now is 02:24 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.