lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 04-28-2014, 08:17 PM   #1
hugger6933
Getting Wild
 
Join Date: Mar 2014
Posts: 135
Default Fire to the coil and coil is new

but still no spark much to my dismay. I checked the red wire [92 Marathon] and fire with the key on so I thought the coil was the problem. Ordered one put it on no spark no cart to ride no golf 7th week in a row it seems like I only have a few min a week to work on it then it is time to go. Bad thing is this is my back up and I still haven't got to run down the tree on my newer electric one either. Any ideas? Let me rephrase that. Please share your thoughts.Thanks Jim
hugger6933 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 04-28-2014, 10:10 PM   #2
redcloud
Gone Wild
 
Join Date: May 2013
Posts: 320
Default Re: Fire to the coil and coil is new

Have you checked the grounds to the engine block?
redcloud is offline   Reply With Quote
Old 04-29-2014, 06:04 AM   #3
hugger6933
Getting Wild
 
Join Date: Mar 2014
Posts: 135
Default Re: Fire to the coil and coil is new

Clean and tight but I will recheck. I think the key was left on for an extended period of time then when trying to put back into service no fire. Jim
hugger6933 is offline   Reply With Quote
Old 04-29-2014, 12:41 PM   #4
ScooterMcTavish
Gone Wild
 
ScooterMcTavish's Avatar
E-Z-GO
 
Join Date: Oct 2009
Location: Manitoba, Canada
Posts: 363
Default Re: Fire to the coil and coil is new

Actually check all your connections including all of the wire harnesses that attach the wires from both the coil (orange/brown pair?) and the engine block (red/blue pair?). Any of these come loose, you'll turn over for days without firing.

In my case, I actually disconnected the harnesses, and spliced the wires together directly to avoid this issue. The harnesses were in rough shape anyways, and I had to cut the wires to pull my engine out.

Also good to move all the spade connectors under the seat around a little bit - sometimes they oxidize and just need a little rub to fix their contact.
ScooterMcTavish is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
exitor coil and coil and head for 1990 C.C. Golf Carts and Parts
G2a yamaha has no fire at coil. Gas Yamaha
No fire at coil Gas Yamaha
coil help Electric EZGO
10.4v to coil wires until i hook up coil, then zero Gas EZGO


All times are GMT -5. The time now is 04:23 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.