lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas golf carts > Gas Columbia ParCar


Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-27-2020, 03:19 PM   #1
Mezmorized6365
Not Yet Wild
 
Join Date: Jun 2020
Posts: 8
Default 1990 Par Car running terrible, if at all...

We bought this golf cart about 6 years ago and had some tweaking to do back the but it ran good. It's now been sitting for about 4 years, we are starting to race again so it was time to check the cart to see if it's good to go for running around at the track.

We tried starting it, it didn't run good at all. So, first thing I did was drain the gas tank, clean it and put new gas in it. That said, we found the fuel lines were cracked and brittle so we replaced them as well. I then read that 2-stroke oil can go bad as well, so I drained, cleaned and added new 2-stroke oil in the tank. We finally thought we had it, it seemed to be running ok, then it started running terrible again so we removed the carb, gave it (and the fuel pump) a cleaning and re-installed... Same.

I want to get a new carb, replace the fuel pump with an electric one and delete the oil injection system and just mix the oil. I can't find a thread to delete the oil injection pump for a Par Car. Can someone help with that?

Also, any suggestions on what I should start with to figure out the problem?
Mezmorized6365 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-28-2020, 01:05 PM   #2
Mezmorized6365
Not Yet Wild
 
Join Date: Jun 2020
Posts: 8
Default Re: 1990 Par Car running terrible, if at all...

A few things...

1. the ignition coil bounces around in the bracket (I'm going to fix that, but possible issue?)
2. does the little square voltage regulator need to be grounded to chassis? (the bolt holding it broke)
Mezmorized6365 is offline   Reply With Quote
Old 07-02-2020, 10:19 AM   #3
Lochlin
Gone Wild
 
Join Date: May 2011
Location: Pittsburgh
Posts: 2,282
Default Re: 1990 Par Car running terrible, if at all...

Regarding the electric fuel pump conversion, check out the sticky on top of the HD forum called "Fuel Draw". It has a lot of info there to include how to install the electric.

The oil injection is a simple fix. Simply snip the oil line going from the oil tank to the carb and plug it with a screw.

The voltage regulator is grounded via one of its three wires and I don't believe that the actual VR housing itself needs grounded. Either way, the VR is only used for the battery charging process and doesn't have anything to do with a cart's performance.

Your coil shouldn't be bouncing around so definitely fix it. As you seem to be getting spark I have some doubts that it is the root cause of your issue.

Really, your symptoms seem to be fuel draw related. Check out that other sticky and for a starting point.
Lochlin is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas golf carts > Gas Columbia ParCar


Thread Tools
Display Modes


Similar Threads
Thread Forum
1990 club car running rough Gas Club Car
1990 DS running or parts DFW Golf Carts and Parts
Cart starts running terrible after about 20 min of run time Gas Yamaha
1989 Marathon running terrible Gas EZGO
1990 ezgo will not turn over after running Gas EZGO


All times are GMT -5. The time now is 06:25 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.