lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts
Electric golf carts Harley Davidson, Melex, Pargo, Taylor-Dunn and other Misc. Carts.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 12-23-2009, 11:14 PM   #1
SSRacinl8r
Not Yet Wild
 
Join Date: Dec 2009
Posts: 5
Default 05 Western (ezgo) Speed Sensor

Hello, Im new to the forum have read many posts. I am working on an 05 Western golf cart. The cart is 42V -(7x6v) batteries less than 1 year old. The diagnostic mode gives the fault of Speed sensor. 1-3 beeps... I have removed the sensor found the magnet on the end of the motor is cracked. Can someone direct me to purchase the needed part, The magnet is different from EZgo this is specific to Western. I have had no luck searching for the magnet or speed sensor for this style cart. The motor is an Advanced high speed model DE3-4009A.
Attached Images
File Type: jpg 002.jpg (69.0 KB, 9 views)
File Type: jpg 006.jpg (72.4 KB, 9 views)
File Type: jpg 011.jpg (43.8 KB, 11 views)
SSRacinl8r is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 12-23-2009, 11:18 PM   #2
Radicalgolfcarts
Gone Wild
E-Z-GO
 
Join Date: Jun 2008
Location: LINWOOD, MI
Posts: 1,362
Default Re: 05 Western (ezgo) Speed Sensor

That looks like thats off of a CC? I think that I have one laying around the shop!! I believe that I changed the same thing the other day on a CC.
Radicalgolfcarts is offline   Reply With Quote
Old 12-24-2009, 12:09 AM   #3
SSRacinl8r
Not Yet Wild
 
Join Date: Dec 2009
Posts: 5
Default Re: 05 Western (ezgo) Speed Sensor

I would be interested in that magnet from the end of the motor. I went to RCC and seen the EZgo version of this magnet, looks different. They (RCC) are helpin out too trying to get in touch with Westerns previous owners to find out where to get replacement. I tried the website www.adcmotors.com I see the sensor on their motors, I will call them to find out. Thanks for the help!!
SSRacinl8r is offline   Reply With Quote
Old 12-24-2009, 12:12 AM   #4
Radicalgolfcarts
Gone Wild
E-Z-GO
 
Join Date: Jun 2008
Location: LINWOOD, MI
Posts: 1,362
Default Re: 05 Western (ezgo) Speed Sensor

Let me know if I can help!!
Radicalgolfcarts is offline   Reply With Quote
Old 12-24-2009, 12:17 AM   #5
SSRacinl8r
Not Yet Wild
 
Join Date: Dec 2009
Posts: 5
Default Re: 05 Western (ezgo) Speed Sensor

Does the magnet you have look like the cracked one in the first picture, minus the crack I hope? lol I can purchase if you can ship. thanks
SSRacinl8r is offline   Reply With Quote
Old 12-24-2009, 12:19 AM   #6
Radicalgolfcarts
Gone Wild
E-Z-GO
 
Join Date: Jun 2008
Location: LINWOOD, MI
Posts: 1,362
Default Re: 05 Western (ezgo) Speed Sensor

The second pic looks just like the housing!!
Radicalgolfcarts is offline   Reply With Quote
Old 12-24-2009, 12:20 AM   #7
SSRacinl8r
Not Yet Wild
 
Join Date: Dec 2009
Posts: 5
Default Re: 05 Western (ezgo) Speed Sensor

Im upgrading my wifes 98' EZgo 36v to 48v with contactor, Wires, and controller (hoping to get DCX 500 or equivelant.) keeping motor stock for now. I believe its a Regen DCS, your help is much appreciated. Thanks
SSRacinl8r is offline   Reply With Quote
Old 12-24-2009, 12:21 AM   #8
Radicalgolfcarts
Gone Wild
E-Z-GO
 
Join Date: Jun 2008
Location: LINWOOD, MI
Posts: 1,362
Default Re: 05 Western (ezgo) Speed Sensor

Whatever you need please let me know!! Im glad to help!!
Radicalgolfcarts is offline   Reply With Quote
Old 12-24-2009, 12:23 AM   #9
SSRacinl8r
Not Yet Wild
 
Join Date: Dec 2009
Posts: 5
Default Re: 05 Western (ezgo) Speed Sensor

I think the housing may be ok, just a cracked magnet causing cut out during acceleration. then takes off again. maybe both items needed. you all are the pro's the PDS cart directed me to the speed sensor. (diag mode)
SSRacinl8r is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts


Thread Tools
Display Modes


Similar Threads
Thread Forum
Western/ezgo id year? Electric EZGO
precedent motor speed sensor Electric Club Car
oil level sensor ? Gas Club Car
Oil pressure sensor, Gov and Lift Kit info Gas EZGO
how do I by-pass voltage sensor on total charge Electric EZGO


All times are GMT -5. The time now is 02:38 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.