lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-21-2010, 07:26 PM   #1
Jbake515
Not Yet Wild
 
Join Date: Aug 2010
Posts: 4
Default G2 won't charge battery

I have a 1990 g2 that will not charge the battery. It has all new battery cable connections and a new voltage regulator. It will start and run fine if I charge the battery, but with the cart running, the voltage reading across the battery is the same with it not running.

Is the actual charging circuit built into the starter? Are there any tests I can perform on it? Thanks.
Jbake515 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-22-2010, 05:40 AM   #2
technoid
Getting Wild
Yamaha
 
Join Date: Aug 2010
Location: PA
Posts: 138
Default Re: G2 won't charge battery

Quote:
Originally Posted by Jbake515 View Post
I have a 1990 g2 that will not charge the battery. It has all new battery cable connections and a new voltage regulator. It will start and run fine if I charge the battery, but with the cart running, the voltage reading across the battery is the same with it not running.

Is the actual charging circuit built into the starter? Are there any tests I can perform on it? Thanks.
It sounds like the generator needs to be flashed. Or its just not producing voltage. Since its a combo start/generate, flashing might not be needed. Are you sure all your connections are good? Is this a solid state regulator or is it the old coil and contact type? When you have it running place a volt meter across the output of the generator and battery negative. As you speed the motor up the voltage should rise above 12v. If you lift the ground wire from the regulator the generator should go to full output. It could also be you have a bad regulator right out of the box. Check all your fuses too. I am not to familiar with your wiring but maybe a fuse wire link was installed and its blown. I would go over all wires and connections end to end with an ohm meter. Sorry I could not be of more help.
technoid is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
8 Volt battery charge ??? Electric Club Car
Does anyone run a battery charge meter Extreme DC!
new battery wont charge Electric EZGO
Monitor battery charge Electric Yamaha
Battery cant keep charge Gas EZGO


All times are GMT -5. The time now is 11:40 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.