lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Closed Thread
 
Thread Tools Display Modes
Old 12-20-2008, 05:40 PM   #1
david411
Not Yet Wild
Harley Davidson
 
Join Date: Dec 2008
Location: dalton ga
Posts: 57
Default 89 almost alive

ok guys i got this thing running kinda, i got the carb cleaned out and got it started but im not to sure if the battery is dying or the starter/generater is going bad.i can jump it of but it doesnt seem like the battery is charging
david411 is offline  
Old 12-20-2008, 10:17 PM   #2
CaptEd
Not Yet Wild
 
Join Date: Oct 2008
Posts: 22
Default Re: 89 almost alive

Ok Dave, the latest from the new manual. With a Volt meter you should have at least 12 volts at the battery. If not re-charge and check again, should be about 13.8 volts with a good charge. If you still have low voltage, replace the battery. With the engine running, you should have 15 volts at the regulator. That is measuring between the two outside terminals on the voltage regulator. D- the black wires, D+ the red wire. If not, they say replace the regulator. Of course there is the normal statement of Clean battery posts, check for any loose connections, visual inspection of all wires for burns, or broken.
Hope this helps. Capt. Ed
CaptEd is offline  
Old 12-21-2008, 09:53 AM   #3
david411
Not Yet Wild
Harley Davidson
 
Join Date: Dec 2008
Location: dalton ga
Posts: 57
Default Re: 89 almost alive

thank ,yours does have the robin 244 cc engine dosnt it,cause the spark plug in mine is a champion but it not L92-YC
david411 is offline  
Old 12-21-2008, 11:12 AM   #4
CaptEd
Not Yet Wild
 
Join Date: Oct 2008
Posts: 22
Default Re: 89 almost alive

Yes mine is a 244 cc, and I am going by what the manual says.
CaptEd is offline  
Old 12-21-2008, 11:55 AM   #5
david411
Not Yet Wild
Harley Davidson
 
Join Date: Dec 2008
Location: dalton ga
Posts: 57
Default Re: 89 almost alive

ok i cant get mine to start,its like its not get fire but i checked the plug and it had spark,the plug that is in mine is a lot smaller then the one the manual calls for so ill try it.the guy i buoght this thing from i think just used anything that he could find on it
david411 is offline  
Old 12-21-2008, 08:34 PM   #6
david411
Not Yet Wild
Harley Davidson
 
Join Date: Dec 2008
Location: dalton ga
Posts: 57
Default Re: 89 almost alive

i got it to start and go about a 100 yards then thats all it has,i think i have run ops i am about to take this **** thing to a shop
david411 is offline  
Old 12-21-2008, 08:49 PM   #7
CaptEd
Not Yet Wild
 
Join Date: Oct 2008
Posts: 22
Default Re: 89 almost alive

Have you checked the timing?? I had the same problem as you, the guy that sold me my cart used about anything he could find to make it run. After much scratching my head, I bought the manual and have been having pretty good luck since then. The timing on my cart was so far off it could have been in a totally different county. LOL
CaptEd is offline  
Old 12-22-2008, 08:12 AM   #8
david411
Not Yet Wild
Harley Davidson
 
Join Date: Dec 2008
Location: dalton ga
Posts: 57
Default Re: 89 almost alive

no i havent ,i did take off the oil pump to see if that wounld help the guy i bought it from told me to mix gas and oil and us the pump but im not to sure its to much oil,i put that new plug on it and it black with oil in 5 min
david411 is offline  
Old 12-22-2008, 02:50 PM   #9
CaptEd
Not Yet Wild
 
Join Date: Oct 2008
Posts: 22
Default Re: 89 almost alive

You should not be mixing and using pump at the same time. I trust myself more than some pump, so I am mixing my gas. 1 oz. to the gallon, normal use, 1 1/2 oz. to the gallon hard use. I have too many dollars invested in my engine to burn it up because a pump did not work. Capt. Ed
CaptEd is offline  
Old 12-23-2008, 12:12 AM   #10
david411
Not Yet Wild
Harley Davidson
 
Join Date: Dec 2008
Location: dalton ga
Posts: 57
Default Re: 89 almost alive

i took the oil tank off but i havent had tim to try it ,by the time i get home its late most nights,but i will ,by the way i read it some where but dont remember ,where is it u fish and for what.just wondering
david411 is offline  
Closed Thread
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
dead or alive????? Lifted Golf Carts
its alive!!! Gas Yamaha


All times are GMT -5. The time now is 04:50 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.