lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 02-16-2008, 03:34 PM   #1
dragonpiercer
Not Yet Wild
 
Join Date: Feb 2008
Posts: 3
Question 1999 EZ GO stopped running

Greetings,
I have an EZ GO 1999 model. This morning it was being driven and the driver stopped to chit chat. When he put his foot on the gas (from a stopped position) he heard an audible pop (I am not sur if the pop was the normal cylinoid noise or something else), and the cart would not go. I get a minimum 6.2 volts from each battery, and the cylinoid reads 38.2 volts when I depress the gas pedal (this is reading on the small bolts to the front, not the larger outside ones). I have checked/cleaned posts and connections on both the motor and the batteries. The F/R switch appears tp be fine with no burnt wires visible. The back up alarm sounds as it should in reverse. Around the cylinoid/throttle control there is a faint smell of burnt wire/plastic, but nothing visible at all. I blew everything off to clean it and still no evidence of burned wires. I turned the headlights on and hit the gas and the cylinoid clicks (as it has every time) and the headlights do not even flicker, so I am sure the battery/voltage is not an issue. Any help would be great. Thank you.
dragonpiercer is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 02-16-2008, 05:40 PM   #2
gornoman
Stay thirsty my friends!
 
gornoman's Avatar
Mixed Breed
 
Join Date: Jan 2007
Location: Suburban Chicago
Posts: 24,110
Default Re: 1999 EZ GO stopped running

Is you forward/reverse switch activated directly by the lever or is there a long metal rod running from the lever location to under the passenger seat? This will determine which drive system you have.
gornoman is offline   Reply With Quote
Old 02-16-2008, 07:25 PM   #3
dragonpiercer
Not Yet Wild
 
Join Date: Feb 2008
Posts: 3
Exclamation Re: 1999 EZ GO stopped running

It has the long rod.
dragonpiercer is offline   Reply With Quote
Old 02-16-2008, 10:07 PM   #4
gornoman
Stay thirsty my friends!
 
gornoman's Avatar
Mixed Breed
 
Join Date: Jan 2007
Location: Suburban Chicago
Posts: 24,110
Default Re: 1999 EZ GO stopped running

That means you have a Series or Fleet cart. Let's start by giving every large cable a good twist and tug. If all the cables (even back to the motor) are intact, lift the rear of the cart on stands and jump the large posts of the solenoid with a 6g cable. If the cart runs when key is on, cart is in gear, and pedal depressed, the solenoid has failed and needs replacing.
gornoman is offline   Reply With Quote
Old 02-16-2008, 11:02 PM   #5
phasetim
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: 1999 EZ GO stopped running

do you own a voltmeter?
phasetim is offline   Reply With Quote
Old 02-17-2008, 04:44 PM   #6
dragonpiercer
Not Yet Wild
 
Join Date: Feb 2008
Posts: 3
Default Re: 1999 EZ GO stopped running

I will jump the large posts and see what happens...I do have a voltmeter. Thanks
dragonpiercer is offline   Reply With Quote
Old 02-17-2008, 06:57 PM   #7
caddymankc
WILD
 
caddymankc's Avatar
E-Z-GO
 
Join Date: May 2007
Location: lebanon county,pa
Posts: 1,266
Default Re: 1999 EZ GO stopped running

Then you could check how many volts are going into the solinoid the press the peddle and see how many volts are going out, if theres no voltage its ether somewhere before the solinoid or its time to buy a new one.
caddymankc is offline   Reply With Quote
Old 02-17-2008, 07:20 PM   #8
phasetim
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: 1999 EZ GO stopped running

Well if the solenoid is clicking its nothing before the solenoid...... If its not clicking test voltage to small post see if you are getting voltage... If so, its nothing before the solenoid, replace solenoid. If no voltage, find problem before solenoid......

If your solenoid clicks test voltage going through as caddymankc suggested. Keeping in mind there is a resistor providing voltage to the controller side.

If solenoid is fine, follow voltage into controller B+; Then you can follow voltage coming out of your controller. With enough patience, or a wiring diagram you should be able to determine where the voltage should be..
phasetim is offline   Reply With Quote
Old 04-12-2012, 11:29 AM   #9
50Ladybug
Not Yet Wild
 
Join Date: Apr 2012
Posts: 1
Default Re: 1999 EZ GO stopped running

My taillight would not go off-discharged the batteries. Now all i get is a flicker on the charge meter on the dash. Where do I start to fix?
Thanks-
50ladybug
Port Ludlow WA
50Ladybug is offline   Reply With Quote
Old 04-12-2012, 12:50 PM   #10
Bowslayer
Gone Wild
Club Car
 
Join Date: Aug 2011
Location: Tyler, Texas
Posts: 661
Default Re: 1999 EZ GO stopped running

Quote:
Originally Posted by 50Ladybug View Post
My taillight would not go off-discharged the batteries. Now all i get is a flicker on the charge meter on the dash. Where do I start to fix?
Thanks-
50ladybug
Port Ludlow WA
A good place to start would probably be starting a new thread with your question rather than replying to a thread from 2008.
If you completely discharged your batteries you will have to charge them individually or 2 at a time until you get enough voltage for the charger to see them.
Bowslayer is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
1999 EZGO Jacobson Workhorse Gas EZGO
Another 1999 Club Car gasser Golf Carts and Parts
1999 Club Car gasser Golf Carts and Parts
my 1st golf cart 1999 EZgo Gas EZGO


All times are GMT -5. The time now is 04:48 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.