lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 04-13-2023, 12:30 AM   #31
Cartmaster
British born Nincompoop
 
Cartmaster's Avatar
E-Z-GO
 
Join Date: Feb 2007
Location: United Kingdom
Posts: 2,256
Default Re: Voltage issue.

Try spraying some premixed fuel directly into the carb while cranking. If it fires up for a few seconds, the engine is fine and you need to look again at fuel delivery. If no fire, then you need to look deeper as to why.
Cartmaster is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 04-13-2023, 08:58 AM   #32
cart around
Test before replacing
E-Z-GO
 
Join Date: Aug 2013
Location: Ohio side of the Pennsylvania border.
Posts: 3,341
Default Re: Voltage issue.

Cartmaster is right. Spray some mixed fuel in there to see if it fires. If not, remove the exhaust pipe and move the piston up and down. Look in the to see if you can spot a square hole in the side of the piston. If you see it, the piston is in backwards. If there is no hole, we start thinking about crankshaft seals. Hope it fires when you squirt some fuel.

No, the wheels should not turn until the engine is running and both clutches engage.
cart around is offline   Reply With Quote
Old 04-23-2023, 06:55 PM   #33
KevinRB
Not Yet Wild
Cushman
 
Join Date: Oct 2014
Location: S.W. Indiana
Posts: 44
Default Re: Voltage issue.

Ok sorry I was away a while but yesterday I sprayed gas into carburetor like Cartmaster and cart around said and started sounding like it was hitting. I had it on jack stands and kept at it and it FINIALY started. I took it out on the road and drove it about a half mile and it seemed to do good. I have a short but steep hill going into my backyard and it went up it with no problem at all. I drove around the backyard in both forward and reverse with no issues. I owe a big thank you to you all on here that helped guide me through getting it started and explaining how this type of cart works. Now that it's running and driving I'll start going over it and see what needs to be done. I didn't want to spend money on it until I knew it would run seeing how it sat for 15 years. Thanks again and I'll be tapping into your knowledge again as I move along.
Kevin.
KevinRB is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
HELP!! Voltage issue Lithium EZGO
always a voltage issue Electric Club Car
98 gas ezgo voltage issue Gas EZGO
EZ GO Voltage drop issue Electric EZGO
Troubleshooting Voltage Issue Gas EZGO


All times are GMT -5. The time now is 12:43 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.