lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 04-01-2011, 09:55 AM   #1
bradb511
Not Yet Wild
 
Join Date: Oct 2010
Posts: 22
Default 1980 g1 no low speed

The cart starts and runs fine but seems it only has 1 speed, wide open throttle or none at all. Is there any way to get the starter to engage earlier without having to have the pedal almost all the way down? Would really like some low speed for driving around at the deer lease.
bradb511 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 04-01-2011, 11:31 AM   #2
chuddly
Gone Wild
 
chuddly's Avatar
Yamaha
 
Join Date: Mar 2010
Location: Eminence, IN
Posts: 534
Default Re: 1980 g1 no low speed

I had the same problem. most of my problem is that the butterfly was set too far open (wich helps with top speed) but also it will not let you go at less throttle. take the ball and socket arm off and shorten it up a bit and see how that works for ya
chuddly is offline   Reply With Quote
Old 04-04-2011, 12:31 PM   #3
bradb511
Not Yet Wild
 
Join Date: Oct 2010
Posts: 22
Default Re: 1980 g1 no low speed

Anyone else have any other ideas? Im going to tinker with it tonight
bradb511 is offline   Reply With Quote
Old 04-04-2011, 02:39 PM   #4
chuddly
Gone Wild
 
chuddly's Avatar
Yamaha
 
Join Date: Mar 2010
Location: Eminence, IN
Posts: 534
Default Re: 1980 g1 no low speed

thats really about it.....should be pretty simple
chuddly is offline   Reply With Quote
Old 04-04-2011, 08:58 PM   #5
haus513
Getting Wild
 
haus513's Avatar
Yamaha
 
Join Date: Jul 2010
Location: cincinnati ohio
Posts: 129
Default Re: 1980 g1 no low speed

chuddly answer that one should just need to adjust.
haus513 is offline   Reply With Quote
Old 04-05-2011, 10:07 AM   #6
bradb511
Not Yet Wild
 
Join Date: Oct 2010
Posts: 22
Default Re: 1980 g1 no low speed

Thanks, It was way too short. Works like a champ now. Now If I can get this dang oil pump to quit leaking
bradb511 is offline   Reply With Quote
Old 04-05-2011, 12:33 PM   #7
sho305
Vegas modded 420
 
sho305's Avatar
Yamaha
 
Join Date: Jun 2009
Location: West MI
Posts: 15,327
Default Re: 1980 g1 no low speed

The switch under the pedal should click right after the pedal moves, its adjustable. Then the carb should be set to idle slowly, once you move the top of pedal about 1" past where it starts the throttle should begin to open. You should have full throttle with it floored. A problem with G1 is the cylinder boot gets oil on it and the carb will twist, that messes up throttle adjustments. Take the carb out and clean the boot and carb with carb cleaner/etc and install it straight up, it should not move now. Adjust the governor if you need more speed, don't mess with the throttle after setting it up properly.
sho305 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
1980 g1/a1 Gas Yamaha
1980 G1 is there a lift kit Gas Yamaha
1980 G1 intro Gas Yamaha
1980 F&R Switch Golf Carts and Parts
1980 G1 swing arm Gas Yamaha


All times are GMT -5. The time now is 11:09 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.