lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Star and Fairplay


Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-07-2017, 06:07 PM   #1
msparsons
Not Yet Wild
 
Join Date: May 2016
Posts: 6
Default Star trouble

Hey all...picked this Star up as a project for a fairly good price. Previous owners said it needed new batteries. Not denying that as they are 5 years old Trojan T-105, but I don think that is all that's wrong with it. Batteries charge to 47 volts, but it won't move in F or R.
I can hear the silinoid engaging, but nothing.

Anyone have a schematic for a star. 2008 or 2010 if I had to guess. Any suggestions on where to begin?
Attached Images
File Type: jpg IMG_3928.jpg (212.1 KB, 0 views)
msparsons is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-07-2017, 07:13 PM   #2
Golf cart guy
Gone Wild
 
Golf cart guy's Avatar
 
Join Date: May 2015
Location: Central Florida
Posts: 2,114
Default Re: Star trouble

does it have the Curtis sepex controller in it? If so, it should be flashing a code out
Golf cart guy is offline   Reply With Quote
Old 07-08-2017, 09:13 AM   #3
msparsons
Not Yet Wild
 
Join Date: May 2016
Posts: 6
Default Re: Star trouble

Hey GCG, it does. 1-3 which tells me the speed sensor isn't recognized or bad. I found that out last night. I wouldn't think that would stop the cart from moving?
msparsons is offline   Reply With Quote
Old 07-08-2017, 03:59 PM   #4
msparsons
Not Yet Wild
 
Join Date: May 2016
Posts: 6
Default Re: Star trouble

Fixed the speed sensor by cleaning the contacts. No errors now. I did find loose contacts to the silinoid I think as it stopped engaging this morning until got under the cart and adjusted the peddle housing.

Did some more testing. Even thought the batteries read 47v. When the gas peddle is depressed, the voltage drops to ~31-32v at the controller. That is telling me the batteries are bad (which I knew) and could be the culprit.
msparsons is offline   Reply With Quote
Old 07-09-2017, 07:38 AM   #5
Golf cart guy
Gone Wild
 
Golf cart guy's Avatar
 
Join Date: May 2015
Location: Central Florida
Posts: 2,114
Default Re: Star trouble

Get the batteries fixed
Golf cart guy is offline   Reply With Quote
Old 07-19-2017, 10:32 AM   #6
msparsons
Not Yet Wild
 
Join Date: May 2016
Posts: 6
Default Re: Star trouble

Ok. Back from vacation and picked up a new set of crowns. It will move at 1/4 throttle, but slow and stutters. Any further and I get a loud clicking and it stops. Lights on the sepex flash 4/4. Aux relay did not close.

Is that the silinoid? Sounds like that's where the clicking is coming from.
Attached Images
File Type: jpg IMG_0953.jpg (171.9 KB, 0 views)
msparsons is offline   Reply With Quote
Old 07-19-2017, 05:12 PM   #7
msparsons
Not Yet Wild
 
Join Date: May 2016
Posts: 6
Default Re: Star trouble

Well go figure. It started working...somewhat. Not 100% smooth in throttle, but it goes forward and reverse. Took it for a short ride and it goes. Every once in a while, it still gets a loud clicking mentioned earlier. Still researching that.
msparsons is offline   Reply With Quote
Old 07-22-2017, 07:23 PM   #8
Golf cart guy
Gone Wild
 
Golf cart guy's Avatar
 
Join Date: May 2015
Location: Central Florida
Posts: 2,114
Default Re: Star trouble

Could have stuck motor brushes due to sitting. They may free up if you drive it. If ot still shudders at the low end, you may have to pull the motor
Golf cart guy is offline   Reply With Quote
Old 08-11-2017, 09:21 AM   #9
msparsons
Not Yet Wild
 
Join Date: May 2016
Posts: 6
Default Re: Star trouble

Update: the cart has been running fine lately. I did take it to the shop last week to have the lights repaired (needed a new 48v convo and new wiring). They also laid a new program in the controller to turn everything up. Supposed to be back today, so we shall see.
Next up is to find a new/used ezgo txt body to swap it out with and upgrade the lights to led.
msparsons is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Star and Fairplay


Thread Tools
Display Modes


Similar Threads
Thread Forum
Star EV just died Star and Fairplay
ever hear of a star car? Electric Club Car
New Star Star and Fairplay
Star Star and Fairplay
When you wish upon a star.... Golf Carts and Parts


All times are GMT -5. The time now is 09:42 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.