lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 01-09-2020, 06:16 PM   #11
House
Not Yet Wild
 
Join Date: Jan 2020
Posts: 17
Default Re: Starter engages but wont start or move

Btw, i cant find my serial # referenced any where on charts? Seems to skip right over my cart #.. any help on reading my cart # would be great. Dont really wanna buy a carb for the wrong year.. i did notice that theres not an inline filter running to carb so im definitely putting one on once i figure all this out.
House is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 01-09-2020, 06:29 PM   #12
meimk
Gone Wild
 
meimk's Avatar
Club Car
 
Join Date: Jun 2011
Location: Northern Indiana
Posts: 2,826
Default Re: Starter engages but wont start or move

The serial # you gave in your top post translates to a 1995 G-9
meimk is offline   Reply With Quote
Old 01-09-2020, 06:43 PM   #13
CP241
Nincompoop village idiot
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: Michigan
Posts: 9,677
Default Re: Starter engages but wont start or move

110psi is way low for a G9. did you test it with the throttle held wide open?

It should be in the 165-170psi range. I don't think it's going to run at 110psi, if it does manage to fire off it's certainly not going to run very well.
CP241 is online now   Reply With Quote
Old 01-11-2020, 05:26 AM   #14
House
Not Yet Wild
 
Join Date: Jan 2020
Posts: 17
Default Re: Starter engages but wont start or move

Thanks for the info on year and model. When i checked compression i took guel line off carb and clamped it, then held the pedal down all the way while turning it over. This is correct procedure right ? So your saying my compression is way to low ? Think i read in another thread something about crank seals being worn out. Would that be the issue ?
House is offline   Reply With Quote
Old 01-11-2020, 08:46 AM   #15
CP241
Nincompoop village idiot
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: Michigan
Posts: 9,677
Default Re: Starter engages but wont start or move

Crank seals being worn and causing issues is on 2 stroke motors like the old ezgo marathons and the yamaha G1. The G9 is a 4 stroke, a worn crank seal is just gonna leak oil, but it's not going to affect how the motor runs.

I'd start with a valve adjustment and then check compression again. See where it's at. If jts still low, pour about a tablespoon or so of oil in the spark plug hole. If the compression numbers jump way up from there, its worn rings.
CP241 is online now   Reply With Quote
Old 01-11-2020, 09:06 AM   #16
meimk
Gone Wild
 
meimk's Avatar
Club Car
 
Join Date: Jun 2011
Location: Northern Indiana
Posts: 2,826
Default Re: Starter engages but wont start or move

Quote:
Originally Posted by CP241 View Post
Crank seals being worn and causing issues is on 2 stroke motors like the old ezgo marathons and the yamaha G1. The G9 is a 4 stroke, a worn crank seal is just gonna leak oil, but it's not going to affect how the motor runs.

I'd start with a valve adjustment and then check compression again. See where it's at. If jts still low, pour about a tablespoon or so of oil in the spark plug hole. If the compression numbers jump way up from there, its worn rings.
Also, make sure the carb is actually opening with the pedal down. I've had many Yamaha's (not necessarily G-9s) break the throttle cable and NOT open the carb butterfly. Switch under the pedal engages the starter independently of the cable functioning.
meimk is offline   Reply With Quote
Old 01-11-2020, 10:00 AM   #17
House
Not Yet Wild
 
Join Date: Jan 2020
Posts: 17
Default Re: Starter engages but wont start or move

Ok thank you gentlemen. Ill check & do these things and post what comes out of it...
House is offline   Reply With Quote
Old 01-11-2020, 01:02 PM   #18
House
Not Yet Wild
 
Join Date: Jan 2020
Posts: 17
Default Re: Starter engages but wont start or move

Throttle valve working. I think i may have found the issue? Bolts on valve cover were loose. Like barely finger tight.. & gasket is shot. almost non-existent . Do yall think was the problem? I checked valve gaps. Seemed a touch tight on .004. Should i just leave them alone? it ran fine before it started acting up.. i gotta order a new gasket so itll be awhile b4 i can get it back together & report back
House is offline   Reply With Quote
Old 01-12-2020, 12:01 PM   #19
slonomo
Searching for The Way
 
slonomo's Avatar
Yamaha
 
Join Date: Oct 2009
Location: Medina, Ohio (NEOHIO)
Posts: 11,441
Default Re: Starter engages but wont start or move

Just having the valve cover loose will not cause your problem, but definitely plan to fix that, as a loose cover and no gasket will leak oil.

Get your valves checked. Make sure you read up on the correct procedures. The way I do it is I make sure one valve is fully open, then check the other. Repeat.

Also, take the spark plug out and rotate the engine by hand, watch to see that the valves are opening and closing and not binding or sticking.

The compression does sound a little low. Squirt some oil in the cylinder and cycle the engine. Try it again when you know the valve are set correctly.
slonomo is offline   Reply With Quote
Old 01-12-2020, 03:38 PM   #20
CP241
Nincompoop village idiot
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: Michigan
Posts: 9,677
Default Re: Starter engages but wont start or move

Tight valves will cause lower compression. If they're top tight it can prevent them from closing fully, and lose compression.

I'd adjust the valves and see what happens. If that doesnt help, try a bit of oil in the spark plug hole.

I'd also recommend a leak down test if you can
CP241 is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
2010 TXT ezgo wont move/start Electric EZGO
Golf cart will start but wont move Gas EZGO
99 ezgo will start but wont move when cold Gas EZGO
1984 Marathon 2pg wont start after new (used)starter... Gas EZGO
92 ezgo gas wont start, run, move nothing Gas EZGO


All times are GMT -5. The time now is 09:46 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.