lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-22-2020, 07:33 PM   #1
chapalincharlie
Not Yet Wild
E-Z-GO
 
Join Date: Aug 2020
Location: Texas
Posts: 14
Default '09 GAS EZGO RXV starts 95%+ of the time then...

I bought a used GAS 2009 RXV. It runs well and usually starts immediately. Occasionally it will not start. This has happened both when the engine was hot and when it was cold. The cables from the battery to the solenoid are clean and tight. It start more than 95 % off the time. On the rare occasions when it doesn't start, I will push the gas pedal multiple times until it starts.
chapalincharlie is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-23-2020, 12:36 PM   #2
chapalincharlie
Not Yet Wild
E-Z-GO
 
Join Date: Aug 2020
Location: Texas
Posts: 14
Default Re: '09 GAS EZGO RXV starts 95%+ of the time then...

Bump
chapalincharlie is offline   Reply With Quote
Old 08-23-2020, 12:45 PM   #3
kgsc
Gone Wild
 
kgsc's Avatar
Mixed Breed
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 9,801
Default Re: '09 GAS EZGO RXV starts 95%+ of the time then...

Couple of questions. Is the starter an Hitachi or AMD ? And what color is the starter pulley? Something to try next time is lift the seat and spin the drive clutch over one turn and try again..
kgsc is online now   Reply With Quote
Old 08-24-2020, 07:52 PM   #4
Cs80727
Not Yet Wild
 
Join Date: Jun 2020
Posts: 1
Default Re: '09 GAS EZGO RXV starts 95%+ of the time then...

I also have 2009 gas EZGO TXT that does this exact same thing.

I just took it out for a spin and it fired right up after sitting for a few days in the garage. Drove about 3/4 mile to the mailbox, hopped out to grab the mail and then it wouldn’t start. Took me about 6 or 7 times of pushing the accelerator pedal before it would start again.

At first I thought it was the fuel pump, and replaced it, but no difference. Have put new spark plugs on too. Any ideas?
Cs80727 is offline   Reply With Quote
Old 08-25-2020, 08:55 AM   #5
kgsc
Gone Wild
 
kgsc's Avatar
Mixed Breed
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 9,801
Default Re: '09 GAS EZGO RXV starts 95%+ of the time then...

Same questions as I asked above..
kgsc is online now   Reply With Quote
Old 08-27-2020, 10:41 PM   #6
4mula1fan
Gone Wild
 
4mula1fan's Avatar
E-Z-GO
 
Join Date: Mar 2010
Location: Western KY
Posts: 217
Default Re: '09 GAS EZGO RXV starts 95%+ of the time then...

Mine does it, but it is just overcoming the compression stroke. I simply give it time and hold the pedal in the start position until she starts. It has the original starter/gen.
4mula1fan is offline   Reply With Quote
Old 08-28-2020, 12:24 PM   #7
kgsc
Gone Wild
 
kgsc's Avatar
Mixed Breed
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 9,801
Default Re: '09 GAS EZGO RXV starts 95%+ of the time then...

Again.. what starter does it have? Hitachi or AMD? And what color is the pulley? If it is gold you can replace it with the black one which is smaller so gives it more torque.
kgsc is online now   Reply With Quote
Old 08-30-2020, 04:19 PM   #8
chapalincharlie
Not Yet Wild
E-Z-GO
 
Join Date: Aug 2020
Location: Texas
Posts: 14
Default Re: '09 GAS EZGO RXV starts 95%+ of the time then...

Quote:
Originally Posted by kgsc View Post
Couple of questions. Is the starter an Hitachi or AMD ? And what color is the starter pulley? Something to try next time is lift the seat and spin the drive clutch over one turn and try again..
I could not see any marking on the starter itself that identified a brand. The pulley is gray.

Will follow your advice regarding the drive clutch next time this happens. Your help is appreciated.

Thank you
Mike
chapalincharlie is offline   Reply With Quote
Old 08-30-2020, 04:34 PM   #9
chapalincharlie
Not Yet Wild
E-Z-GO
 
Join Date: Aug 2020
Location: Texas
Posts: 14
Default Re: '09 GAS EZGO RXV starts 95%+ of the time then...

I should have specified, when this happens the engine does not even turn over.
chapalincharlie is offline   Reply With Quote
Old 08-31-2020, 07:18 AM   #10
kgsc
Gone Wild
 
kgsc's Avatar
Mixed Breed
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 9,801
Default Re: '09 GAS EZGO RXV starts 95%+ of the time then...

I’m betting you have the Hitachi starter with the gold grey 3” pulley. Once warm if the starter catches during the compression stroke it doesn’t have enough torque to spin it.
kgsc is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
87 EZGO Starts but no Power Gas EZGO
86 ezgo starts but doesn't always go Gas EZGO
Cart starts running terrible after about 20 min of run time Gas Yamaha
Starts first time then wont till cooldown Gas EZGO
95 Medalist Starts Every Time....Kinda Gas EZGO


All times are GMT -5. The time now is 01:28 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.