lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha
Electric Yamaha Electric Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-20-2021, 10:56 AM   #1
twilliams81
Gone Wild
 
Join Date: Aug 2016
Posts: 572
Default G29 has a grinding in rear end when pedal is pressed but no movement

G29 has a grinding in the rear end when the pedal is pressed but the cart won't move in forward or reverse. Both hubs look good so they're not stripped out. Any idea where to go to next? I've never tore into one of these rear ends but I imagine it's not an easy task. Thanks
twilliams81 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-20-2021, 11:27 AM   #2
camaroluvz28
Gone Wild
 
camaroluvz28's Avatar
Yamaha
 
Join Date: Sep 2010
Location: Florida
Posts: 1,893
Default Re: G29 has a grinding in rear end when pedal is pressed but no movement

Your gunna want to put cart in tow, disconnect main positive, label all the motor wires and pull the motor...it sounds like maybe your motor coupler or input shaft may have stripped out. both may be worn...be careful when you take the three 10 mm bolts off that are holding the motor on because if they(splines) are indeed stripped out the motor will want to fall out as the last bolt is removed and the motor is very heavy so brace for that as well. That's where I would start...
camaroluvz28 is offline   Reply With Quote
Old 09-20-2021, 02:14 PM   #3
twilliams81
Gone Wild
 
Join Date: Aug 2016
Posts: 572
Default Re: G29 has a grinding in rear end when pedal is pressed but no movement

10-4 thanks bud


Sent from my iPhone using Tapatalk
twilliams81 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
03 Series - no movement - grinding in rear end Electric EZGO
Grinding sound from rear end when I let off the go pedal Electric EZGO
No movement if accelerator pressed to quickly? Electric Club Car
97 txt surges when pedal pressed Electric EZGO
jerking as soon as pedal is pressed Electric Club Car


All times are GMT -5. The time now is 10:40 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.