lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-27-2011, 12:16 AM   #1
bigtony55
Not Yet Wild
 
bigtony55's Avatar
Club Car
 
Join Date: Jun 2010
Location: Everett Wa
Posts: 56
Default 1989 gas ezgo gets hot dont want to move

I have a 89 ezgo drove it all around our camping area for about 25-30 minutes went up big hill started acting funny went back down hill and at the bottom stopped moving motor was running fine motor clutch was working fine back clutch wouldnt engage had to get towed back to campsite left it there itsat for 2 days fired it up stepped on the as and cart started moving not like it did before but it did under its on power is the back clutch bad? could the spring be work out and when it got hot got to weak??
bigtony55 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-27-2011, 12:23 PM   #2
ScooterMcTavish
Gone Wild
 
ScooterMcTavish's Avatar
E-Z-GO
 
Join Date: Oct 2009
Location: Manitoba, Canada
Posts: 363
Default Re: 1989 gas ezgo gets hot dont want to move

Hey Big Tony,

When you say (though a bit of punctuation might help here....) after coming down the hill, the motor was running fine, but the back clutch wouldn't engage? If so:
- Was the motor clutch closing and grabbing the belt?
- Was the motor clutch closing and NOT grabbing the belt?
- Was the belt spinning/smoking/turning?
- Was there any visible damage to the belt?
- Was the cart heavily loaded when you went up the hill?

It almost sounds to be like drive belt damage, and you could have hypothetically shaved an already thin belt down by going up the hill, especially as you mentioned it is still not running right.
ScooterMcTavish is offline   Reply With Quote
Old 07-27-2011, 07:02 PM   #3
bigtony55
Not Yet Wild
 
bigtony55's Avatar
Club Car
 
Join Date: Jun 2010
Location: Everett Wa
Posts: 56
Default Re: 1989 gas ezgo gets hot dont want to move

Quote:
Originally Posted by ScooterMcTavish View Post
Hey Big Tony,

When you say (though a bit of punctuation might help here....) after coming down the hill, the motor was running fine, but the back clutch wouldn't engage? If so:
- Was the motor clutch closing and grabbing the belt?
- Was the motor clutch closing and NOT grabbing the belt?
- Was the belt spinning/smoking/turning?
- Was there any visible damage to the belt?
- Was the cart heavily loaded when you went up the hill?

It almost sounds to be like drive belt damage, and you could have hypothetically shaved an already thin belt down by going up the hill, especially as you mentioned it is still not running right.
Hi sorry i tend to ramble on LOL
Yes motor clutch was spinning the belt
The back clutch just wanst moving its like the engine didne have enough power to make the cart move
My buddy took a look and seems to think my carb is shot because of the play in the shaft is quite bad
I tried the cart now and it moved but not very well so i removed the drive belt and reved up the motor as much as i could and the cart wouldnt move and it seemed to have lil throttle response
which leads me to think he was right about the carb
bigtony55 is offline   Reply With Quote
Old 08-02-2011, 08:44 PM   #4
bigtony55
Not Yet Wild
 
bigtony55's Avatar
Club Car
 
Join Date: Jun 2010
Location: Everett Wa
Posts: 56
Default Re: 1989 gas ezgo gets hot dont want to move

Ok I put new carb on runs better but still barely wants to move also put in new drive belt could my exhaust be plugged even though there is smoke coming out also could it be the valve plate on the intake side
bigtony55 is offline   Reply With Quote
Old 08-03-2011, 02:28 PM   #5
ScooterMcTavish
Gone Wild
 
ScooterMcTavish's Avatar
E-Z-GO
 
Join Date: Oct 2009
Location: Manitoba, Canada
Posts: 363
Default Re: 1989 gas ezgo gets hot dont want to move

It doesn't hurt to bbq the muffler, but generally it will cause a bog-down condition.

If there is an issue with the clutches, we'll have to mait for someone else to weigh in here, as clutches are not my specialty.
ScooterMcTavish is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
1998 club car dont move...new batts Electric Club Car
1989 Gas EZGO Gas EZGO
1989 ezgo Electric golf carts
F/S 1989 EZGO Gas Golf Carts and Parts
ezgo 295 carb on 350 engine cart dont have power Gas EZGO


All times are GMT -5. The time now is 03:41 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.