lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 02-22-2009, 04:04 PM   #1
jhbluesman
Not Yet Wild
 
Join Date: Feb 2009
Posts: 23
Default No output on 488 amp. controller

I have a 96 ez-go, lifted, stock motor, 488 amp.controller, 4 ga. cables, and a up graded f/r. switch. It is dead in the water. I can't get any voltage reading out of controller that is 16 months old. I think it needs to be replaced. Got controller from buggies unlimited. I think it is a Curtis on a 1204 footprint. I would like to get it rebuilt if possible, or do I just need to bite the bullet and get a new one? Does anyone one have any suggestions? The motor runs in forward and reverse if I bypass controller.
jhbluesman is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 02-22-2009, 09:07 PM   #2
rusty
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,237
Default Re: No output on 488 amp. controller

Hello jhbluesman and Welcome to the forum.

Be sure to check the systems micro switches & etc. before you bite the bullet on a new controller.

A motor will run without the full functions of the F/R switch and associated microswitches as well as the REED Switch and ITS unit if you just jumper across the controller.

As I said, there are many small items that will render your cart dead.

Check the wiring diagrams and check your system against the diagram that matches your system first. Good Luck.
rusty is offline   Reply With Quote
Old 02-22-2009, 09:10 PM   #3
crash12888
Gone Crazy
 
Join Date: Jan 2007
Location: Chesterfield, Va
Posts: 5,100
Default Re: No output on 488 amp. controller

What is the reading on the pot box? That can cause it as well.
crash12888 is offline   Reply With Quote
Old 02-22-2009, 09:15 PM   #4
BigBlockMan
Gone Wild
 
BigBlockMan's Avatar
 
Join Date: Feb 2007
Location: Southwest Georgia
Posts: 1,469
Default Re: No output on 488 amp. controller

Is it a1204 controller or a 5 pin 1206 in a 1204 case. Either way we can rebuild it and raise the output if needed
BigBlockMan is offline   Reply With Quote
Old 02-24-2009, 08:43 AM   #5
jhbluesman
Not Yet Wild
 
Join Date: Feb 2009
Posts: 23
Default Re: No output on 488 amp. controller

Quote:
Originally Posted by rusty View Post
Hello jhbluesman and Welcome to the forum.

Be sure to check the systems micro switches & etc. before you bite the bullet on a new controller.

A motor will run without the full functions of the F/R switch and associated microswitches as well as the REED Switch and ITS unit if you just jumper across the controller.

As I said, there are many small items that will render your cart dead.

Check the wiring diagrams and check your system against the diagram that matches your system first. Good Luck.
Thanks for your advise. I've checked the micro switches and run continunity checks on the wiring, but have found nothing wrong. I don't know what a REED switch is. Can you give me more info? Thanks
jhbluesman is offline   Reply With Quote
Old 02-24-2009, 08:45 AM   #6
jhbluesman
Not Yet Wild
 
Join Date: Feb 2009
Posts: 23
Default Re: No output on 488 amp. controller

Quote:
Originally Posted by BigBlockMan View Post
Is it a1204 controller or a 5 pin 1206 in a 1204 case. Either way we can rebuild it and raise the output if needed
Thanks for your help. I don't know if I have a 1204 or 1206. Can you tell me how to determine the difference?
Thanks
jhbluesman is offline   Reply With Quote
Old 02-24-2009, 08:48 AM   #7
jhbluesman
Not Yet Wild
 
Join Date: Feb 2009
Posts: 23
Default Re: No output on 488 amp. controller

Quote:
Originally Posted by crash12888 View Post
What is the reading on the pot box? That can cause it as well.
Thanks for your help. I don't know what a pot box is. It doesn't have a variable resister that I know of. Do you mean the ITS?
Thanks
jhbluesman is offline   Reply With Quote
Old 02-24-2009, 08:50 AM   #8
CC-John
prop. A$$hole's Garage
 
CC-John's Avatar
 
Join Date: Dec 2007
Location: Deep inside the Central Scrutinizer (77096)
Posts: 1,568
Default Re: No output on 488 amp. controller

Quote:
Originally Posted by jhbluesman View Post
Thanks for your advise. I've checked the micro switches and run continunity checks on the wiring, but have found nothing wrong. I don't know what a REED switch is. Can you give me more info? Thanks
The reed switch is a safety interlock switch located in the cart's charger receptical.. They're a common trouble spot.. There is a post on here on how to bypass it, just search "reed switch"...
CC-John is offline   Reply With Quote
Old 02-24-2009, 09:11 AM   #9
jhbluesman
Not Yet Wild
 
Join Date: Feb 2009
Posts: 23
Default Re: No output on 488 amp. controller

Quote:
Originally Posted by CC-John View Post
The reed switch is a safety interlock switch located in the cart's charger receptical.. They're a common trouble spot.. There is a post on here on how to bypass it, just search "reed switch"...
Thanks John,
I'll check it out.
jhbluesman is offline   Reply With Quote
Old 02-24-2009, 09:33 AM   #10
jhbluesman
Not Yet Wild
 
Join Date: Feb 2009
Posts: 23
Default Re: No output on 488 amp. controller

Quote:
Originally Posted by CC-John View Post
The reed switch is a safety interlock switch located in the cart's charger receptical.. They're a common trouble spot.. There is a post on here on how to bypass it, just search "reed switch"...
CC-John,
I checked the wire for the reed switch. Someone cut it off the receptical box long ago.
I've had this cart for 2 years and it has worked fine until now. What ever was done must have not affected the cart before. If the wire wasn't on there before, do you think it has anything to dlo with my problem now?
jhbluesman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
charger voltage output for 48v CC Electric Club Car
Generator output voltage? Gas EZGO
850 Amp controller Golf Carts and Parts
controller help Electric EZGO
Need a pds controller Golf Carts and Parts


All times are GMT -5. The time now is 11:29 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.