lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-30-2020, 09:49 PM   #11
R&TBabich
Gone Wild
Club Car
 
Join Date: Apr 2020
Location: 1000 Oaks, SOCAL
Posts: 416
Default Re: DS Runs Slow, No Full Throttle

Quote:
Originally Posted by namyot11 View Post
Everything seems tight to me but I'll check it out again tomorrow. I'm leaning toward it have a bad MCOR. I'd hate to start throwing parts at it without a proper diagnosis.
Do a forum search, I think there are MCOR test procedures there.
R&TBabich is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-09-2020, 07:56 AM   #12
namyot11
Getting Wild
Mixed Breed
 
Join Date: Jul 2011
Location: Wellington, Ohio
Posts: 106
Default Re: DS Runs Slow, No Full Throttle

Almost forgot to post the resolution to my throttle issue. I got under the cart to look at everything better and found that the screw holding the spring on the mcor 4 conversion kit had worked itself loose and would not allow full travel on the actuator rod. In fact, I had to put a larger screw in to tighten it up as it had stripped out in the plastic bracket holder of the mcor. After I did this I was up to 84% of throttle. Then I was able to force a zip tie in behind the throttle pedal and throttle response went to 98%. Close enough! Thanks for all the help and responses. Interesting how many people have the same issue(insufficient throttle response) and there can be a resolution that hasn't been seen before.
namyot11 is offline   Reply With Quote
Old 09-09-2020, 10:11 PM   #13
Left Coast Kiteboarding
Gone Wild
 
Left Coast Kiteboarding's Avatar
Club Car
 
Join Date: Mar 2013
Location: Santa Cruz, Californnistan
Posts: 326
Default Re: DS Runs Slow, No Full Throttle

I had the same issues. Was all linkage related. Before replacing the 2 brackets with bushings in them I was getting 0v-3v on my MCOR. After replacing everything I get almost the full 5v output.
Left Coast Kiteboarding is offline   Reply With Quote
Old 09-10-2020, 08:28 AM   #14
Wakko47
Gone Loco
 
Wakko47's Avatar
Club Car
 
Join Date: Jul 2020
Location: South Florida
Posts: 1,123
Default Re: DS Runs Slow, No Full Throttle

Thanks for posting the update...this may help someone in the future.
Wakko47 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Yamaha G1 Only Runs with full choke and full Throttle Gas Yamaha
G16 only runs full throttle with choke pulled Gas Yamaha
runs full throttle only Gas EZGO
Yamaha g16 only runs full throttle Gas Yamaha
G1 Only runs at full throttle Gas Yamaha


All times are GMT -5. The time now is 03:19 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.