lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-03-2016, 09:18 AM   #1
cbrooks
Not Yet Wild
 
Join Date: Sep 2016
Posts: 9
Default 1990 Ezgo Marathon help!

Hi everyone,

I bought a '90 marathon (3pg robin) awhile back and through this forum have learned alot. The cart had been sitting for awhile and so i have replaced the crankshaft seals and just put on a new carb. Now im stumped and need help...

I am finally getting strong spark and fuel. Compression is right around 100. When turning over i get alot of backfiring through exhaust and it puts out the smoke. It has never fired. The plug is very oily black, but i have the fuel mixed at 1ounce to one gallon.

I know compression is on the low side but thought it should run. I have not had any luck. Any help is appreciated
cbrooks is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-03-2016, 02:40 PM   #2
Sean5545
Gone Wild
E-Z-GO
 
Join Date: Sep 2015
Location: North East, PA
Posts: 186
Default Re: 1990 Ezgo Marathon help!

Do you have a strong blue/white spark? Also after you did the seals did it backfire at all and possibly blow one out?
Sean5545 is offline   Reply With Quote
Old 09-04-2016, 12:12 AM   #3
cart around
Test before replacing
E-Z-GO
 
Join Date: Aug 2013
Location: Ohio side of the Pennsylvania border.
Posts: 3,097
Default Re: 1990 Ezgo Marathon help!

100 psi is fine. Since you already changed the seals, I would take the fuel pump apart, and check the lower diaphragm for rips.
cart around is offline   Reply With Quote
Old 09-05-2016, 04:01 PM   #4
cbrooks
Not Yet Wild
 
Join Date: Sep 2016
Posts: 9
Default Re: 1990 Ezgo Marathon help!

Yes spark is bright blue/white on a brand new ngk plug. I have gone thru the fuel pump before and it was in fine shape. i am getting fuel to the plug.

Could it be the coil?

Seems if im getting spark and fuel it should fire.
cbrooks is offline   Reply With Quote
Old 09-06-2016, 11:20 AM   #5
Sean5545
Gone Wild
E-Z-GO
 
Join Date: Sep 2015
Location: North East, PA
Posts: 186
Default Re: 1990 Ezgo Marathon help!

After you did your crank seals did you install the pickup coil EXACTLY how you removed it? If not your timing could be way way off and while you will have spark it won't be when you need it....just throwing out suggestions. The only other thing coming to mind like I said earlier is one of your crank seals popped back out but if your getting strong flow from the fuel pump that is kinda ruled out
Sean5545 is offline   Reply With Quote
Old 09-07-2016, 06:01 PM   #6
cbrooks
Not Yet Wild
 
Join Date: Sep 2016
Posts: 9
Default Re: 1990 Ezgo Marathon help!

hmmm, well i guess thats possible. I did not mark it but was able to see where it was had previously mounted and thought i had it lined up correctly.

If i have it wrong is there a way to put it back where it needs to be?
cbrooks is offline   Reply With Quote
Old 09-07-2016, 06:47 PM   #7
Sean5545
Gone Wild
E-Z-GO
 
Join Date: Sep 2015
Location: North East, PA
Posts: 186
Default Re: 1990 Ezgo Marathon help!

Do you have a timing light? You can check it without pulling the flywheel....if you lined up the old bolt holes up, you should be 'close enough' to get it to run unless your 180 degrees out (you spun it completely around)
Sean5545 is offline   Reply With Quote
Old 09-10-2016, 07:43 AM   #8
cbrooks
Not Yet Wild
 
Join Date: Sep 2016
Posts: 9
Default Re: 1990 Ezgo Marathon help!

Well sure enough. I pulled the motor again and found I had installed the pickup coil 180 degrees off. Put it all back together and it fired up on first try! Thank you guys so much. Few other things to check out but cart is running great and I've only got $350 into it.
cbrooks is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
FS- 1990 EZGO marathon 3gp Golf Carts and Parts
1990 ezgo marathon 3pg Gas EZGO
1990 EZGO Marathon Golf Carts and Parts
1990 EZGO Marathon Gas EZGO
1990 EZGO Marathon Electric EZGO


All times are GMT -5. The time now is 02:55 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.