lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-11-2010, 10:26 PM   #1
itstheburns327
Not Yet Wild
Mixed Breed
 
Join Date: Sep 2008
Location: Moscow, PA, USA
Posts: 67
Default Gas 99 TXT not charging

i have a 99 txt gas that is not charging while driving. i replaced the battery, and has 12.6 volts, +/- .2v. how can i test the starter/gen to see if its putting out the proper voltage. now, what i have done so far: i connected my battery tester with + on the green wire from the starter gen with - to ground. the reading i saw was 12.6 not running and 0 running. i reversed the battery tester leads and i had the opposite result of 0 not running and 12.6 running. i know the voltage should be at least 13-15 volts. am i testing this correctly either way? would bad brushes cause this and still allow the cart to start or would this require replcing the coils inside the gen? i hope its not the armature. thanks for any of your help.
itstheburns327 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-12-2010, 07:31 AM   #2
BLUE72CAMARO
Gone Wild
E-Z-GO
 
Join Date: Nov 2009
Location: Illinois
Posts: 171
Default Re: Gas 99 TXT not charging

Testing to see if it is charging is as simple as putting your leads on the battery itself. Should test 12.6 volts when cart is not running. When you fire the motor up it should go up to 14v or even a little higher if the battery is down any. Another thing that it could be is the voltage regulator but you will have to wait for someone that is better with electrical components than myself to tell you how to test that.
BLUE72CAMARO is offline   Reply With Quote
Old 08-12-2010, 08:48 AM   #3
scottyb
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 70,696
Default Re: Gas 99 TXT not charging

disconnect the green wire from the generator and use a jumper wire to ground it direct to the battery negative. This test will eliminate the VR from the circuit. Run the motor and test the generator output at the battery again ~ it should be max-ed out at like 16v. IF not, Gen is bad. Check the brushes for wear.
scottyb is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Charging ?'s Electric EZGO
Charging ? Electric EZGO
G16 Gas not charging Gas Yamaha
charging Electric Club Car
36v Charging on '05 PDS Electric EZGO


All times are GMT -5. The time now is 03:45 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.